# Generated from oml4r-2.10.6.gem by gem2rpm -*- rpm-spec -*-
%global gem_name oml4r

Name: rubygem-%{gem_name}
Version: 2.10.6
Release: 1%{?dist}
Summary: Simple OML client library and applications for Ruby
License: MIT
URL: http://oml.mytestbed.net
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9
BuildArch: noarch

%description
This is a simple client library for OML which does not use liboml2 and its
filters, but connects directly to the server using the +text+ protocol.  User
can use this library to create ruby applications which can send measurement to
the OML collection server. The gem ships with some example applications.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/csv2oml
%{_bindir}/ntpq-oml2
%{_bindir}/oml4r-multiple-channel-example
%{_bindir}/oml4r-neuca-beacon
%{_bindir}/oml4r-orca-beacon
%{_bindir}/oml4r-simple-example
%{_bindir}/oml4r-solar
%{_bindir}/oml4r-wlanconfig
%{_bindir}/oml4r-zabbix
%{_bindir}/ping-oml2
%{_bindir}/signalgen
%{_bindir}/test_types
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/omf
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/examples
%{gem_instdir}/oml4r.gemspec

%changelog
* Tue Apr 19 2022 mockbuilder - 2.10.6-1
- Initial package