# Generated from optout-0.0.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name optout

Name: rubygem-%{gem_name}
Version: 0.0.2
Release: 1%{?dist}
Summary: The opposite of getopt(): validate an option hash and turn it into something appropriate for exec() and system() like functions
License: MIT
URL: http://github.com/sshaw/optout
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 2.8.0
# BuildRequires: rubygem(rspec) < 2.9
BuildArch: noarch

%description
Optout helps you write code that will call exec() and system() like
functions. It allows you to map hash keys to command line 
arguments and define validation rules that must be met before the command line
options are created. .


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.rdoc
%{gem_instdir}/spec

%changelog
* Tue Apr 19 2022 mockbuilder - 0.0.2-1
- Initial package