# Generated from rackful-0.2.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rackful

Name: rubygem-%{gem_name}
Version: 0.2.1
Release: 1%{?dist}
Summary: Library for building ReSTful web services with Rack
License: Apache License 2.0
URL: http://github.com/pieterb/Rackful
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Rackful provides a minimal interface for developing ReSTful web services with
Rack and Ruby. Instead of writing HTTP method handlers, you’ll implement
resource objects, which expose their state at URLs.
This version is not backward compatible with v0.1.x.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/CHANGES.md
%license %{gem_instdir}/LICENSE.md
%{gem_instdir}/RACKFUL.md
%{gem_instdir}/example
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/mkdoc.sh
%{gem_instdir}/rackful.gemspec

%changelog
* Wed Apr 20 2022 mockbuilder - 0.2.1-1
- Initial package