# Generated from satre-1.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name satre

Name: rubygem-%{gem_name}
Version: 1.0.0
Release: 1%{?dist}
Summary: A propositional and first order logic library
License: MIT
URL: http://in.tum.de
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(guard-bundler)
# BuildRequires: rubygem(minitest)
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(guard-minitest)
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(rubocop)
# BuildRequires: rubygem(guard-rubocop)
# BuildRequires: rubygem(codeclimate-test-reporter)
BuildArch: noarch

%description
I think therefore I am.
Satre is a library for proportional and first order logic.
It was inspired by the book 'Handbook of practical logic and automated
reasoning' by Harrison, J (2009).
This project originated at the Technical university munich as a students
project in the lecture 'Basics of Artificial Intelligence'.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%{gem_instdir}/Guardfile
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/satre.gemspec

%changelog
* Wed Apr 20 2022 mockbuilder - 1.0.0-1
- Initial package