# Generated from rbt-0.16.7.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rbt

Name: rubygem-%{gem_name}
Version: 0.16.7
Release: 1%{?dist}
Summary: DO NOT YET DOWNLOAD - THIS IS THE BEGINNING OF THE NEW 0.16.x RELEASE SERIES - class Installer is about to be replaced.  This gem is called RBT, which is an abbreviation for "Ruby Build Tools".  Essentially, this project is a collection of different ruby scripts/classes that may aid in the process of compiling or installing programs from source, but also allow installation from binary, from a remote or from a local location (e. g. a file in a directory on the local harddisc/SSD).  There are presently 3819 registered programs available as part of the RBT project.  For more information about the project, have a look at the documentation, which can be found at the bottom right side on the homepage of this gem ( or simply visit the following link: https://www.rubydoc.info/gems/rbt/ )
License: MIT
URL: https://www.rubydoc.info/gems/rbt/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel >= 3.5.3
BuildRequires: ruby >= 2.7.6
BuildArch: noarch

%description
DO NOT YET DOWNLOAD - THIS IS THE BEGINNING OF THE NEW
0.16.x RELEASE SERIES - class Installer is about to be
replaced.
This gem is called RBT, which is an abbreviation for "Ruby Build Tools".
Essentially, this project is a collection of different ruby scripts/classes
that may aid in the process of compiling or installing programs from source,
but also allow installation from binary, from a remote or from a local
location (e. g. a file in a directory on the local harddisc/SSD).
There are presently 3819 registered
programs available as part of the RBT project.
For more information about the project, have a look at the documentation,
which can be found at the bottom right side on the homepage of this
gem ( or simply visit the following link: https://www.rubydoc.info/gems/rbt/ )
.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/all_urls
%{_bindir}/appdir
%{_bindir}/appdir_prefix
%{_bindir}/autosymlink
%{_bindir}/autoupdate_this_program
%{_bindir}/batch_validate_the_cookbook_recipes
%{_bindir}/beautify_configure_help_output
%{_bindir}/binary_of
%{_bindir}/blfs
%{_bindir}/build_detector
%{_bindir}/chainer
%{_bindir}/chroot_compile
%{_bindir}/colour_make
%{_bindir}/colour_make_install
%{_bindir}/compile_in_traditional_manner
%{_bindir}/compile_strategies
%{_bindir}/compile_the_python_addons
%{_bindir}/compile_these_programs
%{_bindir}/compile_via_appdir_prefix_without_symlinking
%{_bindir}/cookbooks
%{_bindir}/copy_these_archives
%{_bindir}/create_app_dir_skeleton
%{_bindir}/create_html_page_for_these_programs
%{_bindir}/create_new_cookbook
%{_bindir}/create_pkgconfig_file
%{_bindir}/create_registered_tags
%{_bindir}/create_snapcraft_file
%{_bindir}/custom_toolchain
%{_bindir}/dual_compile
%{_bindir}/expand_cookbooks
%{_bindir}/extra_information
%{_bindir}/feedback_all_available_formats
%{_bindir}/feedback_description_of
%{_bindir}/feedback_program_description
%{_bindir}/find_all_archive_types
%{_bindir}/find_alternative_archive
%{_bindir}/find_url_for
%{_bindir}/force
%{_bindir}/generate_all_slack_desc_files
%{_bindir}/gitty
%{_bindir}/highest
%{_bindir}/home_dir
%{_bindir}/home_dir_without_symlinking
%{_bindir}/homepage
%{_bindir}/infer_build_system
%{_bindir}/make_app_prefix
%{_bindir}/manual_steps
%{_bindir}/meson_appdir_prefix
%{_bindir}/mirror
%{_bindir}/multi_url_displayer
%{_bindir}/ntrad
%{_bindir}/parse_help
%{_bindir}/paste_blfs
%{_bindir}/query_file_association
%{_bindir}/rbt
%{_bindir}/rbt_action
%{_bindir}/rbt_config
%{_bindir}/rbt_download
%{_bindir}/rbt_make
%{_bindir}/rbt_test_alias
%{_bindir}/remove_symlinks
%{_bindir}/report_host_cpu
%{_bindir}/report_mate_desktop_version
%{_bindir}/report_total_size_of_all_archives
%{_bindir}/root_prefix
%{_bindir}/ruby_libtool
%{_bindir}/run_make_then_make_install
%{_bindir}/scookie
%{_bindir}/search_for_tags
%{_bindir}/show_all_about
%{_bindir}/show_compile_chain
%{_bindir}/show_configuration_options
%{_bindir}/show_versions_of_these_programs
%{_bindir}/simple_appdir_configure
%{_bindir}/software_manager
%{_bindir}/store_abbreviations
%{_bindir}/suggest_cookbook_for
%{_bindir}/symlink_from_to_current
%{_bindir}/to_current
%{_bindir}/toolchain
%{_bindir}/uchroot
%{_bindir}/update_all_ruby_gems
%{_bindir}/update_entry
%{_bindir}/update_kde_applications
%{_bindir}/url_action
%{gem_instdir}/bin
%{gem_instdir}/img
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/doc
%{gem_instdir}/rbt.gemspec
%{gem_instdir}/spec
%{gem_instdir}/test

%changelog
* Thu Mar 28 2024 mockbuilder - 0.16.7-1
- Initial package