# Generated from vanagon-0.53.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name vanagon

Name: rubygem-%{gem_name}
Version: 0.53.0
Release: 1%{?dist}
Summary: Multiplatform build, sign, and ship for Puppet projects
License: Apache-2.0
URL: http://github.com/puppetlabs/vanagon
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.3
BuildRequires: ruby < 4
BuildArch: noarch

%description
Vanagon takes a set of project, component, and platform configuration
files, to perform
multiplatform builds that are packaged into rpms, debs, dmgs, etc.
It has support for calls into Puppet's packaging gem to provide for package
signing and
shipping within the Puppet infrastructure.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/vanagon
%{_bindir}/build
%{_bindir}/inspect
%{_bindir}/ship
%{_bindir}/render
%{_bindir}/repo
%{_bindir}/sign
%{_bindir}/build_host_info
%{_bindir}/build_requirements
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_instdir}/extras
%{gem_libdir}
%{gem_instdir}/resources
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/spec

%changelog
* Fri Sep 13 2024 mockbuilder - 0.53.0-1
- Initial package