# Generated from regtest-2.4.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name regtest

Name: rubygem-%{gem_name}
Version: 2.4.1
Release: 1%{?dist}
Summary: Simple regression testing with Ruby
License: Ruby
URL: https://github.com/janfri/regtest
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.1.0
# BuildRequires: rubygem(rim) >= 2.17
# BuildRequires: rubygem(rim) < 3
BuildArch: noarch

%description
This library supports a very simple way to do regression testing with Ruby. It
is not limited to Ruby projects you can use it also in other contexts where
you
can extract data with Ruby.
You write Ruby scripts with samples. Run these and get the sample results as
results files besides your scripts. Check both the scripts and the results
files in you Source Code Management System (SCM). When you run the scrips on a
later (or even previous) version of your code a simple diff show you if and
how
the changes in your code or environment impact the results of your samples.
This is not a replacement for unit testing but a complement: You can produce a
lot of samples with a small amount of Ruby code (e.g. a large number of
combinations of data).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/.
%license %{gem_instdir}/LICENSE
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/Changelog
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/regtest.gemspec

%changelog
* Sat Sep 14 2024 mockbuilder - 2.4.1-1
- Initial package