# Generated from nanoc-4.13.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name nanoc

Name: rubygem-%{gem_name}
Version: 4.13.2
Release: 1%{?dist}
Summary: A static-site generator with a focus on flexibility
License: MIT
URL: https://nanoc.app/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 3.1
BuildArch: noarch

%description
Nanoc is a static-site generator focused on flexibility. It transforms content
from a format such as Markdown or AsciiDoc into another format, usually HTML,
and lays out pages consistently to retain the site’s look and feel throughout.
Static sites built with Nanoc can be deployed to any web server.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/nanoc
%license %{gem_instdir}/LICENSE
%{gem_instdir}/NEWS.md
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Tue Nov 12 2024 mockbuilder - 4.13.2-1
- Initial package