%global oname base64
Name: java-base64
Version: 2.3.8
Release: 16%{?dist}
Summary: Java class for encoding and decoding Base64 notation
# pom file license comment
# I have released this software into the Public Domain. That
# means you can do whatever you want with it. Really. You don't
# have to match it up with any other open source license -
# just use it. You can rename the files, move the Java packages,
# whatever you want. If your lawyers say you have to have a
# license, contact me, and I'll make a special release to you
# under whatever reasonable license you desire: MIT, BSD, GPL,
# whatever.
License: Public Domain
URL: http://iharder.net/base64/
Source0: https://github.com/omalley/base64/archive/release-%{version}.tar.gz
Patch0: %{name}-2.3.8-elasticsearch.patch
# test deps
BuildRequires: junit
BuildRequires: maven-local
Provides: %{oname} = %{version}-%{release}
BuildArch: noarch
%description
Base64 is a Public Domain Java class for encoding and
decoding Base64 notation. There are one-liner convenience
methods as well as Input and Output Streams.
%package javadoc
Summary: Javadoc for %{name}
%description javadoc
This package contains javadoc for %{name}.
%prep
%setup -q -n %{oname}-release-%{version}
%patch0 -p0
sed -i "s|2.3.9-SNAPSHOT|%{version}|" pom.xml
# Unwanted
%pom_remove_plugin :maven-release-plugin
%pom_remove_plugin :maven-scm-plugin
# Unwanted - disable javadoc source jar
%pom_remove_plugin :maven-source-plugin
%pom_remove_plugin :maven-javadoc-plugin
%mvn_file :%{oname} %{name}
%mvn_file :%{oname} %{oname}
%build
%mvn_build
%install
%mvn_install
(
cd %{buildroot}%{_javadocdir}
ln -sf %{name} %{oname}
)
%files -f .mfiles
%files javadoc -f .mfiles-javadoc
%{_javadocdir}/%{oname}
%changelog
* Thu Jul 25 2019 Fedora Release Engineering - 2.3.8-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri Feb 01 2019 Fedora Release Engineering - 2.3.8-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Fri Jul 13 2018 Fedora Release Engineering - 2.3.8-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Feb 07 2018 Fedora Release Engineering - 2.3.8-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering - 2.3.8-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering - 2.3.8-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Wed Jun 22 2016 gil cattaneo 2.3.8-10
- regenerate build-requires
* Thu Feb 04 2016 Fedora Release Engineering - 2.3.8-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering - 2.3.8-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed Feb 18 2015 gil cattaneo 2.3.8-7
- patched for compatibility with ElasticSearch
* Sat Jun 07 2014 Fedora Release Engineering - 2.3.8-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Fri Mar 28 2014 Michael Simacek - 2.3.8-5
- Use Requires: java-headless rebuild (#1067528)
* Sat Aug 03 2013 Fedora Release Engineering - 2.3.8-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Jul 08 2013 gil cattaneo 2.3.8-3
- switch to XMvn
- minor changes to adapt to current guideline
* Thu May 02 2013 gil cattaneo 2.3.8-2
- fix artifact name, added symlink
- fix javadoc name, added symlink
* Sun Apr 28 2013 gil cattaneo 2.3.8-1
- initial rpm