## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 26
# * files required by tests are not included in published crates:
#   https://github.com/alexheretic/ab-glyph/issues/42
%bcond_with check
%global debug_package %{nil}

%global crate ab_glyph

Name:           rust-ab_glyph
Version:        0.2.29
Release:        %autorelease
Summary:        API for loading, scaling, positioning and rasterizing OpenType font glyphs

License:        Apache-2.0
URL:            https://crates.io/crates/ab_glyph
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
API for loading, scaling, positioning and rasterizing OpenType font
glyphs.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+libm-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libm-devel %{_description}

This package contains library source intended for building other packages which
use the "libm" feature of the "%{crate}" crate.

%files       -n %{name}+libm-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+variable-fonts-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+variable-fonts-devel %{_description}

This package contains library source intended for building other packages which
use the "variable-fonts" feature of the "%{crate}" crate.

%files       -n %{name}+variable-fonts-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Mon Oct 21 2024 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.2.29-2
- fixup! Update to 0.2.29 (rhbz#2241299)

* Sun Oct 20 2024 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.2.29-1
- Update to 0.2.29 (rhbz#2241299)

* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.20-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.20-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Sun Aug 06 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.20-3
- Regenerate with rust2rpm v24

* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.20-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Tue May 02 2023 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.2.20-1
- Update to 0.2.20

* Tue May 02 2023 Tomas Hrcka <thrcka@redhat.com> - 0.2.15-2
- Unretirement request: https://pagure.io/releng/issue/11414

* Thu Mar 10 2022 Rémi Lauzier <remilauzier@protonmail.com> - 0.2.15-1
- Update to version 0.2.15; Fixes RHBZ#2022953

* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.12-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Mon Nov 15 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.2.12-1
- Update to version 0.2.12; Fixes RHBZ#2022953

* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Mon Jul 19 2021 Rémi Lauzier <remilauzier@protonmail.com> - 0.2.11-1
- Initial package; Fixes RHBZ#1978427
## END: Generated by rpmautospec