## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 24
%bcond_without check

%global crate cfonts

Name:           rust-cfonts
Version:        1.2.0
Release:        %autorelease
Summary:        Sexy ANSI fonts for the console

License:        GPL-3.0-or-later
URL:            https://crates.io/crates/cfonts
Source:         %{crates_source}
# Drop Windows dependencies
Patch0:         remove-enable-ansi-support.patch

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
This is a silly little command line tool for sexy ANSI fonts
in the console. Give your cli some love.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
License:        Apache-2.0 AND (Apache-2.0 OR BSL-1.0) AND GPL-3.0-or-later AND ISC AND MIT AND (MIT OR Apache-2.0)

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc README.md
%{_bindir}/cfonts

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build
%{cargo_license} > LICENSE.dependencies

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Mon Jun 17 2024 Alessio <alciregi@fedoraproject.org> - 1.2.0-1
- Update to 1.2.0

* Thu May 23 2024 Fabio Valentini <decathorpe@gmail.com> - 1.1.4-2
- Rebuild with Rust 1.78 to fix incomplete debuginfo and backtraces

* Mon Apr 01 2024 Alessio <alciregi@fedoraproject.org> - 1.1.4-1
- Update to 1.1.4

* Thu Feb 15 2024 alciregi <alciregi@fedoraproject.org> - 1.1.3-2
- Update to 1.1.3

* Thu Feb 15 2024 alessio <alessio@f39.c1v2.oless.xyz> - 1.1.3-1
- Update to 1.1.3

* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Wed Aug 30 2023 alciregi <alciregi@fedoraproject.org> - 1.1.2-1
- Initial import (fedora#2149953).
## END: Generated by rpmautospec