## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 6;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

%global srcname Ultimarc-linux

Name:           ultimarc
Version:        1.2.0
Release:        %autorelease
Summary:        Library and command line utility to configure Ultimarc boards

License:        GPLv2
URL:            https://github.com/katie-snow/Ultimarc-linux
Source0:        %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz

BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  gcc
BuildRequires:  libtool
BuildRequires:  make
BuildRequires:  pkg-config
BuildRequires:  json-c-devel
BuildRequires:  libusbx-devel
# for libudev specifically
BuildRequires:  systemd-devel

%description
This utility will configure the following Ultimarc boards: ServoStik, PACDrive,
IPAC Ultimate, I-Pac 2, I-Pac 4, Mini-Pac, JPAC, UltraStik 360, PacLED64, U-HID
and U-HID Nano. There is support for the PAC 2015 boards, UltraStik 2015 board
and the previous generation of the PAC boards. It uses JSON configuration files
to configure the different boards. It also supports the ability to change the
device ID of the UltraStik 360 boards, allowing for the configuring of four
different boards at once.

%package        devel
Summary:        Development files for %{name}
Requires:       %{name}-libs%{?_isa} = %{version}-%{release}

%description    devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.

%package        libs
Summary:        Shared libraries for %{name}

%description    libs
Libraries to configure Ultimarc boards.

%prep
%autosetup -n %{srcname}-%{version}
# collate JSON config examples
mkdir examples
cp -P src/umtool/*.json examples

%build
./autogen.sh
%configure --disable-static
%make_build

%install
%make_install
rm -f %{buildroot}%{_libdir}/libultimarc.la
# Install udev rules
mkdir -p %{buildroot}%{_udevrulesdir}
cp -P 21-ultimarc.rules %{buildroot}%{_udevrulesdir}

%files
%license LICENSE
%doc AUTHORS ChangeLog NEWS README.cfg README.fw README.md
%doc examples
%{_bindir}/umtool
%{_udevrulesdir}/21-ultimarc.rules

%files libs
%license LICENSE
%{_libdir}/libultimarc.so.1*

%files devel
%{_includedir}/ultimarc
%{_libdir}/libultimarc.so
%{_libdir}/pkgconfig/*.pc

%changelog
## START: Generated by rpmautospec
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Tue Feb 22 2022 Davide Cavalca <dcavalca@fedoraproject.org> - 1.2.0-1
- Update to 1.2.0; Fixes: RHBZ#2057019

* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Sat Jul 10 2021 Björn Esser <besser82@fedoraproject.org> - 1.1.0-3
- Rebuild for versioned symbols in json-c

* Wed Mar 17 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 1.1.0-2.20210314git540d403
- Update build requires

* Sun Mar 14 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 1.1.0-1.20210314git540d403
- Initial package

## END: Generated by rpmautospec