## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 3;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

Name:           corrosion
Version:        0.5.0
Release:        %autorelease
Summary:        Easy Rust and C/C++ Integration
#SourceLicense:  MIT

# Apache-2.0 OR BSL-1.0
# MIT
# MIT OR Apache-2.0
# Unlicense OR MIT
License:        MIT AND (Apache-2.0 OR BSL-1.0) AND (MIT OR Apache-2.0) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown

URL:            https://github.com/corrosion-rs/corrosion
Source:         %{url}/archive/v%{version}/corrosion-%{version}.tar.gz

# drop support for building with older versions of Rust
Patch:          0001-drop-build-rules-that-depend-on-Cargo.lock-files-bei.patch

# port from clap v2 to clap v4 (not yet upstreamable due to MSRV policy)
Patch:          0002-generator-bump-cargo_metadata-dependency-from-0.17-t.patch
Patch:          0003-generator-port-from-clap-v2-to-v3.patch
Patch:          0004-generator-migrate-away-from-deprecated-clap-APIs.patch
Patch:          0005-generator-port-from-clap-v3-to-v4.patch
Patch:          0006-generator-fix-warnings-by-implementing-Display-inste.patch
Patch:          0007-generator-restore-help-CLI-argument.patch

BuildRequires:  cmake
BuildRequires:  cargo-rpm-macros
BuildRequires:  gcc-c++
BuildRequires:  rust

Requires:       cmake

%description
Corrosion, formerly known as cmake-cargo, is a tool for integrating Rust
into an existing CMake project. Corrosion can automatically import
executables, static libraries, and dynamic libraries from a workspace or
package manifest (Cargo.toml file).

%prep
%autosetup -p1
%cargo_prep
find -name "Cargo.lock" -print -delete
rm generator/Compat.Cargo.*

%generate_buildrequires
cd generator
%cargo_generate_buildrequires
cd ..

%build
export RUSTFLAGS="%build_rustflags"
%cmake -DCORROSION_NATIVE_TOOLING:BOOL=ON
%cmake_build
cd generator
%cargo_license_summary
%{cargo_license} > ../LICENSE.dependencies
cd ..

%install
%cmake_install

%files
%license LICENSE
%license LICENSE.dependencies
%doc README.md
%doc RELEASES.md

%{_libexecdir}/corrosion-generator
%{_libdir}/cmake/Corrosion/
%{_datadir}/cmake/{Corrosion,CorrosionGenerator,FindRust}.cmake

%changelog
## START: Generated by rpmautospec
* Fri Sep 20 2024 Fabio Valentini <decathorpe@gmail.com> - 0.5.0-3
- Port generator to cargo_metadata v0.18 and clap v4

* Wed Jul 17 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Sun Jul 07 2024 Steve Cossette <farchord@gmail.com> - 0.5.0-1
- Update to version 0.5.0

* Thu May 23 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.9-1
- Update to version 0.4.9; Fixes RHBZ#2273762

* Thu Mar 14 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.7-1
- Update to version 0.4.7; Fixes RHBZ#2259078

* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.5-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Tue Jan 16 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.5-2
- Set RUSTFLAGS environment variable to ensure it's set correctly

* Sat Dec 02 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.5-1
- Update to version 0.4.5; Fixes RHBZ#2238266

* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Mon Jul 17 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.2-1
- Update to version 0.4.2; Fixes RHBZ#2223187

* Thu Jun 15 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.1-1
- Update to version 0.4.1

* Thu Jun 15 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.5-1
- Initial import (#2209376)
## END: Generated by rpmautospec