%global modulename read-pkg

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-read-pkg
Version:        3.0.0
Release:        1%{?dist}
Summary:        Read a package.json file

License:        MIT
URL:            https://github.com/sindresorhus/read-pkg#readme
Source0:        https://registry.npmjs.org/read-pkg/-/read-pkg-3.0.0.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(load-json-file) >= 4.0.0 with npmlib(load-json-file) < 5.0.0))
BuildRequires:  ((npmlib(normalize-package-data) >= 2.3.2 with npmlib(normalize-package-data) < 3.0.0))
BuildRequires:  ((npmlib(path-type) >= 3.0.0 with npmlib(path-type) < 4.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Read a package.json file

%package 3.0.0
Summary:        Read a package.json file


%description 3.0.0
Read a package.json file

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc readme.md
%license license
%{nodejs_dir}/%{modulename}

%files 3.0.0
%doc readme.md
%license license
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Tue Nov 27 2018 npm2srpm <dshea@redhat.com> - 3.0.0-1
- Package automatically generated by npm2srpm