%global modulename pinkie

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-pinkie
Version:        2.0.4
Release:        1%{?dist}
Summary:        Itty bitty little widdle twinkie pinkie ES2015 Promise implementation

License:        MIT
URL:            https://github.com/floatdrop/pinkie#readme
Source0:        https://registry.npmjs.org/pinkie/-/pinkie-2.0.4.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch


Requires:       npmlib(%{modulename}) = %{version}

%description
Itty bitty little widdle twinkie pinkie ES2015 Promise implementation

%package 2.0.4
Summary:        Itty bitty little widdle twinkie pinkie ES2015 Promise implementation


%description 2.0.4
Itty bitty little widdle twinkie pinkie ES2015 Promise implementation

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc readme.md
%license license
%{nodejs_dir}/%{modulename}

%files 2.0.4
%doc readme.md
%license license
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Tue Nov 20 2018 npm2srpm <dshea@redhat.com> - 2.0.4-1
- Package automatically generated by npm2srpm