%global modulename run-async

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-run-async
Version:        2.3.0
Release:        1%{?dist}
Summary:        Utility method to run function either synchronously or asynchronously using the common `this.async()` style.

License:        MIT
URL:            https://github.com/SBoudrias/run-async#readme
Source0:        https://registry.npmjs.org/run-async/-/run-async-2.3.0.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(is-promise) >= 2.1.0 with npmlib(is-promise) < 3.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Utility method to run function either synchronously or asynchronously using the common `this.async()` style.

%package 2.3.0
Summary:        Utility method to run function either synchronously or asynchronously using the common `this.async()` style.


%description 2.3.0
Utility method to run function either synchronously or asynchronously using the common `this.async()` style.

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc README.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 2.3.0
%doc README.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Mon Nov 19 2018 npm2srpm <dshea@redhat.com> - 2.3.0-1
- Package automatically generated by npm2srpm