%global modulename unified

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-unified
Version:        7.0.2
Release:        1%{?dist}
Summary:        Pluggable text processing interface

License:        MIT
URL:            https://unified.js.org
Source0:        https://registry.npmjs.org/unified/-/unified-7.0.2.tgz



BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(bail) >= 1.0.0 with npmlib(bail) < 2.0.0))
BuildRequires:  ((npmlib(extend) >= 3.0.0 with npmlib(extend) < 4.0.0))
BuildRequires:  ((npmlib(is-plain-obj) >= 1.1.0 with npmlib(is-plain-obj) < 2.0.0))
BuildRequires:  ((npmlib(trough) >= 1.0.0 with npmlib(trough) < 2.0.0))
BuildRequires:  ((npmlib(vfile) >= 3.0.0 with npmlib(vfile) < 4.0.0))
BuildRequires:  ((npmlib(x-is-string) >= 0.1.0 with npmlib(x-is-string) < 0.2.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Pluggable text processing interface

%package 7.0.2
Summary:        Pluggable text processing interface


%description 7.0.2
Pluggable text processing interface

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
%{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc changelog.md
%doc readme.md
%license license
%{nodejs_dir}/%{modulename}

%files 7.0.2
%doc changelog.md
%doc readme.md
%license license
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Wed Dec 5 2018 npm2srpm <dshea@redhat.com> - 7.0.2-1
- Package automatically generated by npm2srpm