%global modulename jsesc

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-jsesc
Version:        2.5.2
Release:        1%{?dist}
Summary:        Given some data, jsesc returns the shortest possible stringified & ASCII-safe representation of that data.

License:        MIT
URL:            https://mths.be/jsesc
Source0:        https://registry.npmjs.org/jsesc/-/jsesc-2.5.2.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch


Requires:       npmlib(%{modulename}) = %{version}

%description
Given some data, jsesc returns the shortest possible stringified & ASCII-safe representation of that data.

%package 2.5.2
Summary:        Given some data, jsesc returns the shortest possible stringified & ASCII-safe representation of that data.


%description 2.5.2
Given some data, jsesc returns the shortest possible stringified & ASCII-safe representation of that data.

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr bin %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr jsesc.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr man %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}

mkdir -p %{buildroot}%{_bindir}
ln -s %{npmlib_dir}/%{modulename}/%{version}/bin/jsesc %{buildroot}/%{_bindir}/jsesc

mkdir -p %{buildroot}%{_mandir}/man1
cp %{buildroot}%{npmlib_dir}/%{modulename}/%{version}/man/jsesc.1 %{buildroot}/%{_mandir}/man1/jsesc.1

mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc LICENSE-MIT.txt
%doc README.md
%{_bindir}/jsesc
%{_mandir}/man1/jsesc.1*
%{nodejs_dir}/%{modulename}

%files 2.5.2
%doc LICENSE-MIT.txt
%doc README.md
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Mon Nov 26 2018 npm2srpm <dshea@redhat.com> - 2.5.2-1
- Package automatically generated by npm2srpm