%global modulename minipass

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-minipass
Version:        2.3.5
Release:        1%{?dist}
Summary:        minimal implementation of a PassThrough stream

License:        ISC
URL:            https://github.com/isaacs/minipass#readme
Source0:        https://registry.npmjs.org/minipass/-/minipass-2.3.5.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(safe-buffer) >= 5.1.2 with npmlib(safe-buffer) < 6.0.0))
BuildRequires:  ((npmlib(yallist) >= 3.0.0 with npmlib(yallist) < 4.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
minimal implementation of a PassThrough stream

%package 2.3.5
Summary:        minimal implementation of a PassThrough stream


%description 2.3.5
minimal implementation of a PassThrough stream

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc README.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 2.3.5
%doc README.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Fri Nov 16 2018 npm2srpm <dshea@redhat.com> - 2.3.5-1
- Package automatically generated by npm2srpm