%global modulename wrapped

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-wrapped
Version:        1.0.1
Release:        1%{?dist}
Summary:        consistent interface for 

License:        MIT
URL:            https://github.com/MatthewMueller/wrapped#readme
Source0:        https://registry.npmjs.org/wrapped/-/wrapped-1.0.1.tgz



BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(co) = 3.1.0))
BuildRequires:  ((npmlib(sliced) >= 1.0.1 with npmlib(sliced) < 2.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
consistent interface for 

%package 1.0.1
Summary:        consistent interface for 


%description 1.0.1
consistent interface for 

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
%{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc History.md
%doc Readme.md
%{nodejs_dir}/%{modulename}

%files 1.0.1
%doc History.md
%doc Readme.md
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Thu Dec 6 2018 npm2srpm <dshea@redhat.com> - 1.0.1-1
- Package automatically generated by npm2srpm