%global modulename levn

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-levn
Version:        0.3.0
Release:        1%{?dist}
Summary:        Light ECMAScript (JavaScript) Value Notation - human written, concise, typed, flexible

License:        MIT
URL:            https://github.com/gkz/levn
Source0:        https://registry.npmjs.org/levn/-/levn-0.3.0.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(prelude-ls) >= 1.1.2 with npmlib(prelude-ls) < 1.2.0))
BuildRequires:  ((npmlib(type-check) >= 0.3.2 with npmlib(type-check) < 0.4.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Light ECMAScript (JavaScript) Value Notation - human written, concise, typed, flexible

%package 0.3.0
Summary:        Light ECMAScript (JavaScript) Value Notation - human written, concise, typed, flexible


%description 0.3.0
Light ECMAScript (JavaScript) Value Notation - human written, concise, typed, flexible

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr lib %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc README.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 0.3.0
%doc README.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Mon Nov 19 2018 npm2srpm <dshea@redhat.com> - 0.3.0-1
- Package automatically generated by npm2srpm