%global modulename vfile

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-vfile
Version:        3.0.1
Release:        1%{?dist}
Summary:        Virtual file format for text processing

License:        MIT
URL:            https://github.com/vfile/vfile#readme
Source0:        https://registry.npmjs.org/vfile/-/vfile-3.0.1.tgz



BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(is-buffer) >= 2.0.0 with npmlib(is-buffer) < 3.0.0))
BuildRequires:  ((npmlib(replace-ext) = 1.0.0))
BuildRequires:  ((npmlib(unist-util-stringify-position) >= 1.0.0 with npmlib(unist-util-stringify-position) < 2.0.0))
BuildRequires:  ((npmlib(vfile-message) >= 1.0.0 with npmlib(vfile-message) < 2.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Virtual file format for text processing

%package 3.0.1
Summary:        Virtual file format for text processing


%description 3.0.1
Virtual file format for text processing

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr core.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
%{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc changelog.md
%doc readme.md
%license license
%{nodejs_dir}/%{modulename}

%files 3.0.1
%doc changelog.md
%doc readme.md
%license license
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Wed Dec 5 2018 npm2srpm <dshea@redhat.com> - 3.0.1-1
- Package automatically generated by npm2srpm