# Generated by go2rpm
%bcond_without check

# https://github.com/ns1/ns1-go
%global goipath         gopkg.in/ns1/ns1-go.v2
%global forgeurl        https://github.com/ns1/ns1-go
Version:                2.4.3

%gometa

%global common_description %{expand:
Golang API client for NS1.}

%global golicenses      LICENSE.txt
%global godocs          README.md _examples

Name:           %{goname}
Release:        %autorelease
Summary:        Golang API client for NS1

License:        ASL 2.0
URL:            %{gourl}
Source0:        %{gosource}

# Remove in F43
Provides: golang-gopkg-ns1-2 = %{version}-%{release}
Obsoletes: golang-gopkg-ns1-2  < 2.4.3-8

%global godevelheader %{expand:
Provides: golang-gopkg-ns1-2-devel = %{version}-%{release}
Obsoletes: golang-gopkg-ns1-2-devel < 2.4.3-8}

BuildRequires:  golang(github.com/stretchr/testify/assert)

%if %{with check}
# Tests
BuildRequires:  golang(github.com/stretchr/testify/mock)
BuildRequires:  golang(github.com/stretchr/testify/require)
%endif

%description
%{common_description}

%gopkg

%prep
%goprep

%install
%gopkginstall

%if %{with check}
%check
%gocheck
%endif

%gopkgfiles

%changelog
%autochangelog