# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}

%global crate av1-grain

Name:           rust-av1-grain
Version:        0.2.2
Release:        %autorelease
Summary:        Helpers for generating and parsing AV1 film grain data

License:        BSD-2-Clause
URL:            https://crates.io/crates/av1-grain
Source:         %{crates_source}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Helpers for generating and parsing AV1 film grain data.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+create-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+create-devel %{_description}

This package contains library source intended for building other packages which
use the "create" feature of the "%{crate}" crate.

%files       -n %{name}+create-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+diff-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+diff-devel %{_description}

This package contains library source intended for building other packages which
use the "diff" feature of the "%{crate}" crate.

%files       -n %{name}+diff-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+estimate-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+estimate-devel %{_description}

This package contains library source intended for building other packages which
use the "estimate" feature of the "%{crate}" crate.

%files       -n %{name}+estimate-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+itertools-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+itertools-devel %{_description}

This package contains library source intended for building other packages which
use the "itertools" feature of the "%{crate}" crate.

%files       -n %{name}+itertools-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+nom-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+nom-devel %{_description}

This package contains library source intended for building other packages which
use the "nom" feature of the "%{crate}" crate.

%files       -n %{name}+nom-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+num-rational-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+num-rational-devel %{_description}

This package contains library source intended for building other packages which
use the "num-rational" feature of the "%{crate}" crate.

%files       -n %{name}+num-rational-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+parse-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+parse-devel %{_description}

This package contains library source intended for building other packages which
use the "parse" feature of the "%{crate}" crate.

%files       -n %{name}+parse-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serialize-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serialize-devel %{_description}

This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.

%files       -n %{name}+serialize-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+v_frame-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v_frame-devel %{_description}

This package contains library source intended for building other packages which
use the "v_frame" feature of the "%{crate}" crate.

%files       -n %{name}+v_frame-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog