## START: Set by rpmautospec
## (rpmautospec version 0.4.1)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 3;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1.8.1
%bcond_without check
%global debug_package %{nil}
# Avoid noarch package built differently on different architectures
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^golang\\(golang.org/x/sys/cpu\\)$

# https://github.com/golang/crypto
%global goipath  golang.org/x/crypto
%global forgeurl https://github.com/golang/crypto
Version:         0.18.0

%global godevelheader %{expand:
Provides: golang(golang.org/x/crypto/ssh/testdata) =  %{version}-%{release}
Provides: golang(golang.org/x/crypto/ssh/testdata)(commit=%commit) = %{version}-%{release}}

%gometa

%global common_description %{expand:
Go supplementary cryptography libraries.}

%global golicenses      LICENSE PATENTS
%global godocs          CONTRIBUTING.md README.md

%global gosupfiles curve25519/const_amd64.h ssh/testdata/*

Name:           %{goname}
Release:        %autorelease
Summary:        Go supplementary cryptography libraries

License:        BSD-3-Clause
URL:            %{gourl}
Source0:        %{gosource}

%description %{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires

%install
%gopkginstall

%if %{with check}
%check
# internal/wycheproof: depends on Go modules
%gocheck -d internal/wycheproof
%endif

%gopkgfiles

%changelog
## START: Generated by rpmautospec
* Tue Jan 09 2024 Mark E. Fuller <mark.e.fuller@gmx.de> - 0.18.0-3
- Uncommitted changes

* Tue Jan 09 2024 Mark E. Fuller <mark.e.fuller@gmx.de> - 0.18.0-2
- RPMAUTOSPEC: unresolvable merge
## END: Generated by rpmautospec