# Generated by go2rpm 1.6.0
%bcond_without check

# https://github.com/sj14/astral
%global goipath         github.com/sj14/astral
Version:                0.1.2

%gometa

%global common_description %{expand:
Go calculations for the position of the sun and moon.}

%global golicenses      LICENSE
%global godocs          AUTHORS README.md

Name:           astral
Release:        2%{?dist}
Summary:        Go calculations for the position of the sun and moon

# Upstream license specification: Apache-2.0
License:        ASL 2.0
URL:            %{gourl}
Source0:        %{gosource}

%description
%{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires

%build
for cmd in cmd/* ; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license LICENSE
%doc AUTHORS README.md
%{_bindir}/*

%gopkgfiles

%changelog
* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Mon May 30 2022 Link Dupont <linkdupont@fedoraproject.org> - 0.1.2-1
- Initial package (RHBZ#2091776)