## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 2;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1.5.0
%bcond_without check

# https://github.com/guptarohit/asciigraph
%global goipath         github.com/guptarohit/asciigraph
Version:                0.5.5

%gometa

%global common_description %{expand:
Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with
no other dependencies.}

%global golicenses      LICENSE
%global godocs          examples README.md

Name:           asciigraph
Release:        %autorelease
Summary:        Makes lightweight ASCII line graphs

# Upstream license specification: BSD-3-Clause
License:        BSD
URL:            %{gourl}
Source0:        %{gosource}

BuildRequires:  go-rpm-macros

%description
%{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires

%build
for cmd in cmd/* ; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license %{golicenses}
%doc %{godocs}
%{_bindir}/asciigraph

%gopkgfiles

%changelog
* Wed Jan 18 2023 Fedora Release Engineering <releng@fedoraproject.org> 0.5.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Tue Oct 04 2022 Major Hayden <major@mhtx.net> 0.5.5-1
- Update to 0.5.5

* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.5.4-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Tue Jul 19 2022 Maxwell G <gotmax@e.email> 0.5.4-4
- Rebuild for
  CVE-2022-{1705,32148,30631,30633,28131,30635,30632,30630,1962} in golang

* Sat Jun 18 2022 Robert-André Mauchin <zebob.m@gmail.com> 0.5.4-3
- Rebuilt for CVE-2022-1996, CVE-2022-24675, CVE-2022-28327,
  CVE-2022-27191, CVE-2022-29526, CVE-2022-30629

* Fri Jun 17 2022 Robert-André Mauchin <zebob.m@gmail.com> 0.5.4-2
- Rebuilt for CVE-2022-1996, CVE-2022-24675, CVE-2022-28327,
  CVE-2022-27191, CVE-2022-29526, CVE-2022-30629

* Tue May 03 2022 Major Hayden <major@mhtx.net> 0.5.4-1
- Update to 0.5.4

* Mon Feb 21 2022 Major Hayden <major@redhat.com> 0.5.3-1
- Update to 0.5.3

* Wed Jan 19 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.5.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Mon Nov 29 2021 Major Hayden <major@redhat.com> 0.5.2-2
- First package for version 0.5.2 🎉

* Mon Nov 29 2021 Major Hayden <major@redhat.com> 0.5.2-1
- Initial import (#2015526)