## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 3;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1.7.0
%bcond_without check

# https://github.com/fullstorydev/grpcurl
%global goipath         github.com/fullstorydev/grpcurl
Version:                1.8.7

%gometa

%global goname grpcurl

%global common_description %{expand:
Like cURL, but for gRPC: Command-line tool for interacting with gRPC servers.}

%global golicenses      LICENSE
%global godocs          README.md

Name:           %{goname}
Release:        %autorelease
Summary:        Like cURL, but for gRPC: Command-line tool for interacting with gRPC servers

License:        MIT
URL:            %{gourl}
Source:         %{gosource}

%description
%{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires

%build
%gobuild -o %{gobuilddir}/bin/%{name} %{goipath}/cmd/%{name}

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license LICENSE
%doc README.md
%{_bindir}/*

%gopkgfiles

%changelog
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> 1.8.7-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Wed Aug 10 2022 Maxwell G <gotmax@e.email> 1.8.7-2
- Rebuild to fix FTBFS

* Tue Aug 09 2022 Mikel Olasagasti Uranga <mikel@olasagasti.info> 1.8.7-1
- Update to 1.8.7 - Closes rhbz#2116727

* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> 1.8.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Tue Jul 19 2022 Maxwell G <gotmax@e.email> 1.8.6-4
- Rebuild for
  CVE-2022-{1705,32148,30631,30633,28131,30635,30632,30630,1962} in golang

* Sat Jun 18 2022 Robert-André Mauchin <zebob.m@gmail.com> 1.8.6-3
- Rebuilt for CVE-2022-1996, CVE-2022-24675, CVE-2022-28327,
  CVE-2022-27191, CVE-2022-29526, CVE-2022-30629

* Sat Apr 16 2022 Fabio Alessandro Locati <me@fale.io> 1.8.6-2
- Rebuilt for CVE-2022-27191

* Sun Feb 20 2022 Mikel Olasagasti Uranga <mikel@olasagasti.info> 1.8.6-1
- Initial package - Closes rhbz#2007332