%global __brp_check_rpaths %{nil}
%global packname matuR
%global packver 0.0.1.0
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 0.0.1.0
Release: 1%{?dist}%{?buildtag}
Summary: Athlete Maturation and Biobanding
License: MIT + file LICENSE
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel >= 2.10
Requires: R-core >= 2.10
BuildArch: noarch
BuildRequires: R-CRAN-dplyr
BuildRequires: R-CRAN-ggplot2
BuildRequires: R-CRAN-lubridate
BuildRequires: R-CRAN-tidyr
BuildRequires: R-CRAN-magrittr
BuildRequires: R-CRAN-ggrepel
Requires: R-CRAN-dplyr
Requires: R-CRAN-ggplot2
Requires: R-CRAN-lubridate
Requires: R-CRAN-tidyr
Requires: R-CRAN-magrittr
Requires: R-CRAN-ggrepel
%description
Identifying maturation stages across young athletes is paramount for
talent identification. Furthermore, the concept of biobanding, or grouping
of athletes based on their biological development, instead of their
chronological age, has been widely researched. The goal of this package is
to help professionals working in the field of strength & conditioning and
talent ID obtain common maturation metrics and as well as to quickly
visualize this information via several plotting options. For the methods
behind the computed maturation metrics implemented in this package refer
to Khamis, H. J., & Roche, A. F. (1994)
, Mirwald, R.L et al., (2002)
and Cumming, Sean P. et al.,
(2017) .
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}