%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname Argentum
%global packver 0.5.1
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 0.5.1
Release: 1%{?dist}%{?buildtag}
Summary: Access and Import WMS and WFS Data from Argentine Organizations
License: MIT + file LICENSE
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel
Requires: R-core
BuildArch: noarch
BuildRequires: R-CRAN-httr
BuildRequires: R-CRAN-xml2
BuildRequires: R-CRAN-sf
BuildRequires: R-CRAN-readr
Requires: R-CRAN-httr
Requires: R-CRAN-xml2
Requires: R-CRAN-sf
Requires: R-CRAN-readr
%description
Provides functions to retrieve information from Web Feature Service (WFS)
and Web Map Service (WMS) layers from various Argentine organizations and
import them into R for further analysis. WFS and WMS are standardized
protocols for serving georeferenced map data over the internet. For more
information on these services, see and
.
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}