%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname rang
%global packver 0.3.0
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 0.3.0
Release: 1%{?dist}%{?buildtag}
Summary: Reconstructing Reproducible R Computational Environments
License: GPL (>= 3)
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel >= 3.5.0
Requires: R-core >= 3.5.0
BuildArch: noarch
BuildRequires: R-CRAN-parsedate
BuildRequires: R-CRAN-fastmap
BuildRequires: R-CRAN-jsonlite
BuildRequires: R-CRAN-memoise
BuildRequires: R-CRAN-pkgsearch
BuildRequires: R-CRAN-remotes
BuildRequires: R-utils
BuildRequires: R-CRAN-httr
BuildRequires: R-CRAN-vctrs
BuildRequires: R-CRAN-renv
BuildRequires: R-CRAN-here
Requires: R-CRAN-parsedate
Requires: R-CRAN-fastmap
Requires: R-CRAN-jsonlite
Requires: R-CRAN-memoise
Requires: R-CRAN-pkgsearch
Requires: R-CRAN-remotes
Requires: R-utils
Requires: R-CRAN-httr
Requires: R-CRAN-vctrs
Requires: R-CRAN-renv
Requires: R-CRAN-here
%description
Resolve the dependency graph of R packages at a specific time point based
on the information from various 'R-hub' web services
. The dependency graph can then be used to
reconstruct the R computational environment with 'Rocker'
.
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}