%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname rmacrostrat
%global packver 1.0.0
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 1.0.0
Release: 1%{?dist}%{?buildtag}
Summary: Fetch Geologic Data from the 'Macrostrat' Platform
License: GPL (>= 3)
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel >= 4.0
Requires: R-core >= 4.0
BuildArch: noarch
BuildRequires: R-CRAN-curl
BuildRequires: R-CRAN-geojsonsf
BuildRequires: R-CRAN-httr
BuildRequires: R-CRAN-jsonlite
BuildRequires: R-CRAN-sf
Requires: R-CRAN-curl
Requires: R-CRAN-geojsonsf
Requires: R-CRAN-httr
Requires: R-CRAN-jsonlite
Requires: R-CRAN-sf
%description
Work with the 'Macrostrat' () Web Service (v.2,
) to fetch geological data relevant to the
spatial and temporal distribution of sedimentary, igneous, and metamorphic
rocks as well as data extracted from them.
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}