%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname  cgwtools
%global packver   4.1
%global rlibdir   /usr/local/lib/R/library

Name:             R-CRAN-%{packname}
Version:          4.1
Release:          1%{?dist}%{?buildtag}
Summary:          Miscellaneous Tools

License:          LGPL-3
URL:              https://cran.r-project.org/package=%{packname}
Source0:          %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz


BuildRequires:    R-devel >= 3.5.0
Requires:         R-core >= 3.5.0
BuildArch:        noarch
BuildRequires:    R-methods 
BuildRequires:    R-CRAN-gmp 
Requires:         R-methods 
Requires:         R-CRAN-gmp 

%description
Functions for performing quick observations or evaluations of data,
including a variety of ways to list objects by size, class, etc.  The
functions 'seqle' and 'reverse.seqle' mimic the base 'rle' but can search
for linear sequences. The function 'splatnd' allows the user to generate
zero-argument commands without the need for 'makeActiveBinding' .
Functions provided to convert from any base to any other base, and to find
the n-th greatest max or n-th least min.  In addition, functions which
mimic Unix shell commands, including 'head', 'tail' ,'pushd' ,and 'popd'.
Various other goodies included as well.

%prep
%setup -q -c -n %{packname}

# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
  sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
  sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;

%build

%install

mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;

%files
%{rlibdir}/%{packname}