%global __brp_check_rpaths %{nil}
%global packname cesR
%global packver 0.1.0
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 0.1.0
Release: 1%{?dist}%{?buildtag}
Summary: Access the Canadian Election Study Datasets
License: MIT + file LICENSE
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel >= 3.5.0
Requires: R-core >= 3.5.0
BuildArch: noarch
BuildRequires: R-CRAN-dplyr
BuildRequires: R-CRAN-haven
BuildRequires: R-CRAN-readr
BuildRequires: R-CRAN-labelled
BuildRequires: R-CRAN-tidyr
BuildRequires: R-utils
Requires: R-CRAN-dplyr
Requires: R-CRAN-haven
Requires: R-CRAN-readr
Requires: R-CRAN-labelled
Requires: R-CRAN-tidyr
Requires: R-utils
%description
Makes accessing and loading the Canadian Election Study
(, ,
) surveys into the R workspace more efficient
by downloading a requested survey and loading it as a data object. This
removes the need to locate, download, load, and change working directories
when working with the Canadian Election Study surveys.
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}