%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname stringi
%global packver 1.8.4
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 1.8.4
Release: 1%{?dist}%{?buildtag}
Summary: Fast and Portable Character String Processing Facilities
License: file LICENSE
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel >= 3.4
Requires: R-core >= 3.4
BuildRequires: R-tools
BuildRequires: R-utils
BuildRequires: R-stats
Requires: R-tools
Requires: R-utils
Requires: R-stats
%description
A collection of character string/text/natural language processing tools
for pattern searching (e.g., with 'Java'-like regular expressions or the
'Unicode' collation algorithm), random string generation, case mapping,
string transliteration, concatenation, sorting, padding, wrapping, Unicode
normalisation, date-time formatting and parsing, and many more. They are
fast, consistent, convenient, and - thanks to 'ICU' (International
Components for Unicode) - portable across all locales and platforms.
Documentation about 'stringi' is provided via its website at
and the paper by Gagolewski (2022,
).
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}