%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname ready4
%global packver 0.1.18
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 0.1.18
Release: 1%{?dist}%{?buildtag}
Summary: Develop and Use Modular Health Economic Models
License: GPL-3
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel
Requires: R-core
BuildArch: noarch
BuildRequires: R-CRAN-curl
BuildRequires: R-CRAN-dataverse
BuildRequires: R-CRAN-dplyr
BuildRequires: R-CRAN-gh
BuildRequires: R-CRAN-kableExtra
BuildRequires: R-CRAN-lifecycle
BuildRequires: R-CRAN-magrittr
BuildRequires: R-methods
BuildRequires: R-CRAN-piggyback
BuildRequires: R-CRAN-purrr
BuildRequires: R-CRAN-rlang
BuildRequires: R-CRAN-rvest
BuildRequires: R-stats
BuildRequires: R-CRAN-stringi
BuildRequires: R-CRAN-stringr
BuildRequires: R-CRAN-tibble
BuildRequires: R-CRAN-tidyRSS
BuildRequires: R-CRAN-tidyselect
BuildRequires: R-tools
BuildRequires: R-utils
Requires: R-CRAN-curl
Requires: R-CRAN-dataverse
Requires: R-CRAN-dplyr
Requires: R-CRAN-gh
Requires: R-CRAN-kableExtra
Requires: R-CRAN-lifecycle
Requires: R-CRAN-magrittr
Requires: R-methods
Requires: R-CRAN-piggyback
Requires: R-CRAN-purrr
Requires: R-CRAN-rlang
Requires: R-CRAN-rvest
Requires: R-stats
Requires: R-CRAN-stringi
Requires: R-CRAN-stringr
Requires: R-CRAN-tibble
Requires: R-CRAN-tidyRSS
Requires: R-CRAN-tidyselect
Requires: R-tools
Requires: R-utils
%description
A template model module, tools to help find model modules derived from
this template and a programming syntax to use these modules in health
economic analyses. These elements are the foundation for a prototype
software framework for developing living and transferable models and using
those models in reproducible health economic analyses. The software
framework is extended by other R libraries. For detailed documentation
about the framework and how to use it visit .
For a background to the methodological issues that the framework is
attempting to help solve, see Hamilton et al. (2024)
.
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}