%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname lwc2022
%global packver 1.0.0
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 1.0.0
Release: 1%{?dist}%{?buildtag}
Summary: Langa-Weir Classification of Cognitive Function for 2022 HRS Data
License: MIT + file LICENSE
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel >= 2.10
Requires: R-core >= 2.10
BuildArch: noarch
BuildRequires: R-CRAN-dplyr
Requires: R-CRAN-dplyr
%description
Generates the Langa-Weir classification of cognitive function for the 2022
Health and Retirement Study (HRS) cognition data. It is particularly
useful for researchers studying cognitive aging who wish to work with the
most recent release of HRS data. The package provides user-friendly
functions for data preprocessing, scoring, and classification allowing
users to easily apply the Langa-Weir classification system. For details
regarding the; HRS and Langa-Weir
classifications
.
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}