%global __brp_check_rpaths %{nil}
%global packname  yasp
%global packver   0.2.0
%global rlibdir   /usr/local/lib/R/library

Name:             R-CRAN-%{packname}
Version:          0.2.0
Release:          3%{?dist}%{?buildtag}
Summary:          String Functions for Compact R Code

License:          MIT + file LICENSE
URL:              https://cran.r-project.org/package=%{packname}
Source0:          %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz


BuildRequires:    R-devel
Requires:         R-core
BuildArch:        noarch

%description
A collection of string functions designed for writing compact and
expressive R code. 'yasp' (Yet Another String Package) is simple, fast,
dependency-free, and written in pure R. The package provides: a coherent
set of abbreviations for paste() from package 'base' with a variety of
defaults, such as p() for "paste" and pcc() for "paste and collapse with
commas"; wrap(), bracket(), and others for wrapping a string in flanking
characters; unwrap() for removing pairs of characters (at any position in
a string); and sentence() for cleaning whitespace around punctuation and
capitalization appropriate for prose sentences.

%prep
%setup -q -c -n %{packname}


%build

%install

mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}

test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css

%files
%{rlibdir}/%{packname}