%global __brp_check_rpaths %{nil}
%global __requires_exclude ^libmpi
%global packname  tsutils
%global packver   0.9.4
%global rlibdir   /usr/local/lib/R/library

Name:             R-CRAN-%{packname}
Version:          0.9.4
Release:          1%{?dist}%{?buildtag}
Summary:          Time Series Exploration, Modelling and Forecasting

License:          GPL-3
URL:              https://cran.r-project.org/package=%{packname}
Source0:          %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz


BuildRequires:    R-devel
Requires:         R-core
BuildArch:        noarch
BuildRequires:    R-CRAN-RColorBrewer 
BuildRequires:    R-CRAN-forecast 
BuildRequires:    R-CRAN-MAPA 
BuildRequires:    R-CRAN-plotrix 
Requires:         R-CRAN-RColorBrewer 
Requires:         R-CRAN-forecast 
Requires:         R-CRAN-MAPA 
Requires:         R-CRAN-plotrix 

%description
Includes: (i) tests and visualisations that can help the modeller explore
time series components and perform decomposition; (ii) modelling
shortcuts, such as functions to construct lagmatrices and seasonal dummy
variables of various forms; (iii) an implementation of the Theta method;
(iv) tools to facilitate the design of the forecasting process, such as
ABC-XYZ analyses; and (v) "quality of life" functions, such as treating
time series for trailing and leading values.

%prep
%setup -q -c -n %{packname}

# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
  sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
  sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;

%build

%install

mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;

%files
%{rlibdir}/%{packname}