%global __brp_check_rpaths %{nil}
%global packname ManifoldOptim
%global packver 1.0.1
%global rlibdir /usr/local/lib/R/library
Name: R-CRAN-%{packname}
Version: 1.0.1
Release: 1%{?dist}%{?buildtag}
Summary: An R Interface to the 'ROPTLIB' Library for Riemannian Manifold Optimization
License: GPL (>= 2)
URL: https://cran.r-project.org/package=%{packname}
Source0: %{url}&version=%{packver}#/%{packname}_%{packver}.tar.gz
BuildRequires: R-devel
Requires: R-core
BuildRequires: R-CRAN-Rcpp >= 0.12.0
BuildRequires: R-CRAN-RcppArmadillo
Requires: R-CRAN-Rcpp >= 0.12.0
%description
An R interface to version 0.3 of the 'ROPTLIB' optimization library (see
for more information). Optimize real-
valued functions over manifolds such as Stiefel, Grassmann, and Symmetric
Positive Definite matrices. For details see Martin et. al. (2020)
. Note that the optional ldr package used in
some of this package's examples can be obtained from either JSS
or
from the CRAN archives
.
%prep
%setup -q -c -n %{packname}
# fix end of executable files
find -type f -executable -exec grep -Iq . {} \; -exec sed -i -e '$a\' {} \;
# prevent binary stripping
[ -d %{packname}/src ] && find %{packname}/src -type f -exec \
sed -i 's@/usr/bin/strip@/usr/bin/true@g' {} \; || true
[ -d %{packname}/src ] && find %{packname}/src/Make* -type f -exec \
sed -i 's@-g0@@g' {} \; || true
# don't allow local prefix in executable scripts
find -type f -executable -exec sed -Ei 's@#!( )*/usr/local/bin@#!/usr/bin@g' {} \;
%build
%install
mkdir -p %{buildroot}%{rlibdir}
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname}
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so)
rm -f %{buildroot}%{rlibdir}/R.css
# remove buildroot from installed files
find %{buildroot}%{rlibdir} -type f -exec sed -i "s@%{buildroot}@@g" {} \;
%files
%{rlibdir}/%{packname}