## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

%bcond_with bootstrap

%global srcname contourpy

Name:           python-%{srcname}
Version:        1.0.6
Release:        %autorelease
Summary:        Python library for calculating contours in 2D quadrilateral grids

License:        BSD
URL:            https://contourpy.readthedocs.io/
Source0:        %pypi_source %{srcname}

BuildRequires:  python3-devel
BuildRequires:  gcc-c++

%global _description %{expand:
ContourPy is a Python library for calculating contours of 2D quadrilateral
grids. It is written in C++11 and wrapped using pybind11.

It contains the 2005 and 2014 algorithms used in Matplotlib as well as a newer
algorithm that includes more features and is available in both serial and
multithreaded versions. It provides an easy way for Python libraries to use
contouring algorithms without having to include Matplotlib as a dependency.
}

%description %{_description}

%package -n     python3-%{srcname}
Summary:        %{summary}

%description -n python3-%{srcname} %{_description}

%prep
%autosetup -n %{srcname}-%{version} -p1
%if %{with bootstrap}
sed -i -e '/matplotlib/d' setup.cfg
%endif

%generate_buildrequires
%pyproject_buildrequires -r -x bokeh,test-no-codebase

%build
%pyproject_wheel

%install
%pyproject_install
%pyproject_save_files %{srcname}

%check
%pytest %{?with_bootstrap:-k 'not needs_mpl'}

%files -n python3-%{srcname} -f %{pyproject_files}
%doc README.md

%changelog
* Wed Nov 02 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.6-1
- Update to latest version (#2138650)

* Wed Sep 07 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.5-1
- Update to latest version (#2123693)

* Mon Aug 01 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.4-1
- Update to latest version (#2112705)

* Wed Jul 06 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.3-1
- Update to latest version (#2096172)

* Thu May 19 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.2-3
- Skip code linting tests

* Thu May 19 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.2-2
- Switch to PyPI sources

* Thu May 19 2022 Elliott Sales de Andrade <quantum.analyst@gmail.com> 1.0.2-1
- import #2073692