%define baserelease 2
#build with --define 'testbuild 1' to have a timestamp appended to release
%if "x%{?testbuild}" == "x1"
%define release %{baserelease}.%(date +%%y%%m%%d.%%h%%m.%%s)
%else
%define release %{baserelease}
%endif
Name: streamkoji
Version: 1.1
Release: %{release}%{?dist}
License: redhat-internal
Summary: stream compatibilityi/config. for koji
Source0: stream.conf
Source91: Authors
Source92: COPYING
Source93: README
BuildArch: noarch
Requires: koji >= 1.13
# For the internal CA, 1.24 has it in a different location.
Requires: brewkoji >= 1.26

%description
Config. files for koji to interact with the CentOS Stream instance.

  Eg. koji -p stream <commands>

%prep

%build

%install

mkdir -p $RPM_BUILD_ROOT/etc/koji.conf.d
cp -a %{SOURCE0} $RPM_BUILD_ROOT/etc/koji.conf.d

mkdir -p $RPM_BUILD_ROOT/usr/share/doc/streamkoji
cp -a %{SOURCE91} $RPM_BUILD_ROOT/usr/share/doc/streamkoji
cp -a %{SOURCE92} $RPM_BUILD_ROOT/usr/share/doc/streamkoji
cp -a %{SOURCE93} $RPM_BUILD_ROOT/usr/share/doc/streamkoji

%files
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/koji.conf.d/stream.conf
%doc /usr/share/doc/streamkoji/*

%changelog
* Wed Mar 10 2021 James Antill <jantill@redhat.com> 1.1-2
- Update brewkoji version dep.

* Wed Mar 03 2021 James Antill <jantill@redhat.com> 1.1-1
- Initial buld.