%global pypi_name pgzip
%global pypi_version 0.3.4

Name:           python-%{pypi_name}
Version:        %{pypi_version}
Release:        1%{?dist}
Summary:        A multi-threading implementation of Python gzip module

License:        MIT
URL:            https://github.com/pgzip/pgzip
Source0:        %{pypi_source}
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3dist(setuptools)

%description
pgzip is a multi-threaded gzip implementation for python that increases the compression
and decompression performance. 


%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}

%description -n python3-%{pypi_name}
pgzip is a multi-threaded gzip implementation for python that increases the compression
and decompression performance. 


%prep
%autosetup -n %{pypi_name}-%{pypi_version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install

%files -n python3-%{pypi_name}
%license LICENSE
%doc README.md
%{python3_sitelib}/%{pypi_name}
%{python3_sitelib}/%{pypi_name}-%{pypi_version}-py%{python3_version}.egg-info

%changelog
* Sun Mar 12 2023 Josh Lay <me+fedora@jlay.io> - 0.3.4-1
- Initial package.