%global project clojure
%global artifactId spec.alpha
%global archivename %{artifactId}-%{artifactId}
%global full_version %{version}
Name: clojure-spec-alpha
Epoch: 1
Version: 0.2.176
Release: 2%{?dist}
Summary: Spec is a Clojure library to describe the structure of data and functions
Group: Development/Languages
License: EPL-1.0
URL: https://github.com/%{project}/%{artifactId}/
Source0: https://github.com/%{project}/%{artifactId}/archive/%{artifactId}-%{full_version}.zip
BuildArch: noarch
BuildRequires: maven-local
BuildRequires: mvn(org.codehaus.mojo:exec-maven-plugin)
BuildRequires: mvn(com.theoryinpractise:clojure-maven-plugin)
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
BuildRequires: mvn(org.clojure:clojure)
%description
Spec is a Clojure library to describe the structure of data and functions.
Specs can be used to validate data, conform (destructure) data, explain
invalid data, generate examples that conform to the specs, and automatically
use generative testing to test functions.
%prep
%setup -q -n %{archivename}-%{full_version}
# Remove unpackaged parent pom and add the required groupId
%pom_remove_parent pom.xml
%pom_xpath_inject pom:project "org.clojure"
%pom_xpath_inject pom:project/pom:properties "UTF-8"
%pom_xpath_inject pom:project/pom:properties "src/main/clojure"
%pom_xpath_inject pom:project/pom:properties "src/test/clojure"
# Hook clojure-maven-plugin to maven phases
%pom_xpath_inject "pom:execution[pom:id='clojure-compile']" "compile"
%pom_xpath_inject "pom:execution[pom:id='clojure-test']" "test"
# Add builder helper to copy clojure source files so that
# compiler finds them.
%pom_add_plugin org.codehaus.mojo:build-helper-maven-plugin:1.12 . "
add-clojure-source-dirs
generate-sources
add-source
add-resource
src/main/clojure
add-clojure-test-source-dirs
generate-sources
add-test-source
add-test-resource
src/test/clojure
"
%build
%mvn_build -f
%install
%mvn_install
%files -f .mfiles
%license epl-v10.html
%doc CHANGES.md README.md CONTRIBUTING.md
%changelog
* Sat May 02 2020 Markku Korkeala - 1:0.2.176-2
- Use xmvn-builddep to generate BuildRequires and drop redundant Requires.
* Wed Apr 15 2020 Markku Korkeala - 1:0.2.176-1
- Update upstream to 0.2.176, clojure dependency to 1.9.0
* Mon Apr 13 2020 Markku Korkeala - 1:0.1.143-1
- Update upstream to 0.1.143, clojure dependency to 1.9.0-beta3
- Add builder helper to copy clojure source files
* Sun Apr 12 2020 Markku Korkeala - 1:0.1.134-2
- Hook clojure-maven-plugin goals to maven goals
* Sun Apr 05 2020 Markku Korkeala - 1:0.1.134-1
- Initial package