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CCDciel is a f ree CCD capture software intended for the amateur astronomer.

CCDciel has all funct ionality required for advanced imaging of  celest ial objects including sequences for fully automated
unattended operat ion. But it  is also possible to make simple capture in a manual way.

For devices connect ion it  uses the INDI and ASCOM standards drivers. It  can control the CCD/CMOS camera, focuser,
f ilter wheel, rotator and telescope mount and uses image resolving software such astrometry.net for accurate posit ioning. It
can serve both the beginner astro photographer as the advanced who can take a nap while the equipment is imaging.

You can use CCDciel on Windows, macOS or Linux.
The program is st ill in beta version but it  is now quit  stable and run smoothly on every plat form 
In any case I will appreciate your help for test ing this sof tware and report ing any bug or other problem you may encounter.

A copy of  the program documentat ion in pdf format is included with the program.

To install the program, look a the specif ic instruct ions for your computer and download from SourceForge the version you
need, always get the latest  version as it  is f requent ly improved!

You can ask the user group for any quest ion about the software usage.

The source code is available f rom GitHub

Contact
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CCDciel features
Supported devices

Any ASCOM or INDI camera
Any ASCOM or INDI f ilter wheel
Any ASCOM or INDI focuser
Any ASCOM or INDI rotator
Any ASCOM or INDI mount
Any ASCOM or INDI dome
Any INDI weather stat ion
Any ASCOM Observing condit ion device
Any ASCOM Safety monitor
NO nat ive support  for any device

Program features
Easy to use conf igurable interface
Separate sett ings for preview and capture
Can start  a quick capture without the need to parameter a full sequence
Parameters for saved f iles include opt ions for the capture folder name and the f ile name
Improve the preview image display with predef ined histogram truncat ion and gamma
Predef ined zoom level or f ree zoom with the mouse wheel
Add bull eye to the preview image
Show saturat ion on the preview image
Image magnif ier at  mouse posit ion
Debayer the preview for color sensors
Can stack preview images with single star alignment and dark subtract ion
Show a reference image on screen to help to manually recenter a f rame
Can set a bad pixel map to remove hot pixel in auto-focus and plate-solving preview images
Select  subframe with the mouse
Camera temperature control
Select  camera readout mode depending on the frame use.
Automat ic sky f lat
Automat ic panel f lat
Choose from 3 dif ferent auto-focus method the one that best work with your equipment
Can auto-focus with f ield stars or by slewing to a bright  star
Support  for f ilter of fset  and exposure factor
Focuser temperature compensat ion
Opt ions for periodic refocusing during capture
Automat ic meridian f lip with many opt ions
Show selected star prof ile with HFD and FWHM
Image inspector show stars HFD, sensor t ilt  and f ield curvature
Message log with severity f ilter
Video control and recording with supported INDI camera
Powerful script ing language
Run automated act ion if  the condit ions are not safe.

Plate solving

Automatic precision Goto using plate-solving
Precision Goto can Sync the mount or use a local of fset
Slew to any point  of  solved image
Rotator calibrat ion and rotat ion f rom plate-solving
Plot  DSO in solved images
Arrow show North direct ion.
Mark the posit ion of  the Pole if  in the image frame.
Show solved image in planetarium
Show solved image frame in planetarium
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Auto-guiding

Automatically manage the guiding start /stop/pause during the dif ferent operat ions
Opt ions for automat ic auto-guider dithering
Recovery f rom auto-guiding problem

Automated sequences

Automated sequences with many sequent ial targets
Sequence contain a list  of  target and can indicate a start /stop t ime and repet it ion opt ions
Target is def ined by a name, coordinates, rotator angle, start /end t ime
Target coordinates can be set f rom the planetarium
A moving target can have it 's coordinates updated from the planetarium at the t ime of  the observat ion
Target opt ion include plate-solving Goto, auto-focus posit ion, skip or wait  if  the observing condit ion are not reach
Use horizon prof ile for objects rise/set t ime
Every target use a predef ined plan to not have to type everything again
Plan are mult i-steps, with number and type of  f rame, exposure t ime, gain, binning, f ilter, auto-focus and dither opt ions
A target can also be a script  or an automated sky f lat  at  dusk or dawn
Pause the sequence if  the observing condit ion are not opt imal
Get the program status in a web browser

Interface with other software

Interface with four dif ferent local plate-solving software (Astrometry.net, Astap, Platesolve2, Elbrus)
Interface with two auto-guiding software (Phd2, Linguider)
Interface with two planetarium software (Cartes du Ciel, Hnsky)
Interface with any SAMP applicat ion (Aladin, Topcat, …)
Interface with processing software (Siril)
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Documentation
Tutorial
Start  by this tutorial to quickly get an idea how the program work.

The program screen
Connect ing the equipment
Global conf igurat ion
Focusing
Simple capture
Automated sequence

Reference Manual
This give detailed informat ion on every program aspect. The pages follow the order of  the main menu.

Menu File with the devices conf igurat ion
Menu Edit  with the preferences sett ings
Menu Tools and toolbox
Menu Help
Right click menu
Status bar
CCDciel status web page.
Script ing
Command line opt ions
Image preprocessing

Installation
To install the software look at  the page corresponding to your computer.

Installat ion on Ubuntu, Debian
Installat ion on Linux
Installat ion on Windows
Installat ion on macOS

External dependencies

You must install this sof twares to take full advantage of  CCDciel, at  least  one of  the equipment driver, one for plate solving,
one auto-guider and one planetarium.

Equipment driver
ASCOM
INDI

Plate solving
ASTAP
Astrometry.net
Star Locator Elbrus
PlateSolve 2

Auto-guider
PHD2
Lin_guider

Planetarium
Cartes du Ciel
Hallo Northern SKY

Image preprocessing
Siril
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Credit
Tools

CCDciel make use of  the following development tools:

Free Pascal compiler
Lazarus IDE and library
BGRABitmap component
Synapse library
WCSTools library

Developer

Patrick Chevalley
Han Kleijn

License

Copyright (C) 2015-2017 Patrick Chevalley
http://www.ap-i.net/ccdciel
  
This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 3
of the License, or (at your option) any later version.

https://www.gnu.org/licenses/gpl.html
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Tutorial
1- The program screen
When you start  the program you see the following screen:

On the top you have the standard menu: File, Edit , Tools, Help, and four menus with a icon: Connect, Focus, Capture and
Sequence. The four menus with icons are the same as on the lef t  tabbed menus.

These four tabbed menus are used for connect ing the equipment, focusing the camera, take a capture or run a sequence of
operat ion.

On the bottom lef t  there is the visualisat ion control for the picture preview and on the right  a text  log with act ivity messages.

The taken or loaded images will be displayed in the middle.
The plate solving funct ions are available f rom the image right  click menu.

The layout is under Tools customisables for either a small monitor or laptop. For example if  you do not use a motorized
rotator, you can uncheck the rotator entry under tools to simplify the Capture tab.

You can drag and drop every tool to another part  of  the screen. Just  hold lef t  mouse button down and drag the tool t it le to
one of  the screen border and drop it  by releasing the mouse button.

If  you have a large monitor, you can make all the controls visible at  the same t ime without using the tabs.

Next tutorial >>
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Tutorial
2- Connecting the equipment
When you are a f irst  t ime user, you have to select  f irst  the correct  equipment drivers and set some sett ings.
First  step is to select  INDI interface (typical in Linux) or the ASCOM interface (typical MS-Windows) to communicate with your
camera, mount and any other equipment.
The program will automat ically open the File→devices setup menu.

Create a new prof ile for your equipment.
All the devices and all the program opt ions will be stored in this prof ile, allowing to have completely dif ferent set t ings for your
dif ferent equipments or locat ions.

Select  either INDI

For INDI it  is important the INDI server with all the driver is running before you can click Connect and get  devices list . You
can use IndiStarter for that .

 

or ASCOM interface.

For ASCOM it  is important you install the ASCOM plat form and every required driver before to start  CCDCiel.

 

Select  also the mandatory camera driver and other equipment like mount or focuser but that  can also be done later.

Click okay and program will create a new default  prof ile for your equipment. All the devices and all the program opt ions will be
stored in this default  prof ile. You could later create an addit ional prof ile with dif ferent set t ings, equipment or locat ion.

Next menu will show the default  opt ions. The f irst  thing to do is to set  the capture folder to something like like in Linux to
/home/username/capture which or for windows from the default  C:\ to something like C:\CCDciel

When ready click the OK button.
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Select  the lef t  tab (pointer icon) and locate the Connect button at  the top. The red dot indicates no connect ion to any
device. Below the connect button you will see the mandatory camera, mount if  selected and any other equipment.

Click on Connect and af ter a few seconds the light  should change to green if  all listed equimpment is connected.

In the connect ion phase, the indicat ion light  will f irst  turn orange and f inally green if  all equipment is successfully connected. In
case of  a connect ion failure or if  an error occurs, the indicat ion light  will turn red. All program act ivit ies and errors will be
logged, so in case of  device connect ion problem have look to the log for an error indicat ion.

Devices with a connect ion problem could be disabled temporary in File→devices setup menu. As a bare minimum only an
imaging camera is required to operate.

Next tutorial >>
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Tutorial
3- Global configuration
You access the global conf igurat ion f rom the menu Edit→Preferences.

All this opt ions will be stored in the current prof ile.

There are a number of  opt ions for every part  of  the program and many can be examined later.

 

To start  it  is essent ial you set:

1. a valid folder for the captured images.
2. be sure the temporary folder path contain only ASCII characters.
3. your observatory lat itude and longitude since they are used in several program funct ions.

Next tutorial >>
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Tutorial
4- Focusing
Manual focus

Point  your telescope somewhere high in the sky and set the Preview exposure t ime and binning.
Click on the Loop button.

If  you are way out of  focus start  f irst  with a long 10-15 seconds exposure t ime to see some large
out of  focus stars disk and move the focuser to reduce the size. If  you near the correct  focus
reduce the exposure t ime to 1 seconds less.

Leave the preview looping and click on the Focus tab to show the focuser and
star prof ile

Double click on a star in somewhere the middle of  the captured image. Check the
recorded star intensity for saturat ion or have look to the star prof ile. The
intensity value should be smaller then the sensor maximum value of  typically
65535. In case of  saturat ion select  a fainter star or reduce the exposure t ime.
Checkmark the “Manual focus aid” to magnify the star image.

Use the focuser buttons or manually adjust  the focuser to make the star image
as small and bright  as possible. It  could be benef icial to use a very short  exposure
t ime to reduce the seeing and have a quick visual feedback.

When ready uncheck “Manual focus aid”.

Auto-focus

To conf igure the auto-focus use the focuser calibrat ion wizard to help you set the dif ferent parameters specif ic to your
setup.

Later you can ref ine them in the auto-focus preferences.

Next tutorial >>
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Tutorial
5- Simple capture

Open the Capture tab and set the required opt ions:

The exposure t ime
The binning
The name of the object
The number of  exposures to take
Be sure the type is Light, other set t ing may let  the shutter closed!

You can also choose to dither between exposures and to regularly adjust  the auto-focus.

Dither introduces a small art if icial cyclic drif t  typically required for CMOS sensors when imaging very faint
objects. It  helps to smoothen out unequal sensit ivity of  the individual pixels. Leave his opt ion of f  in the
beginning

Binning combines pixels if  they are too small to record any details and reduces noise. Typically you set this
on 1×1 or for large sensors on 2×2.

If  you have a f ilter wheel you can specif iy the f ilter to use.

You can specify the f rame dimensions if  you don't  want to use the full sensor surface.

If  you have a rotator the green/red light  indicate if  it  is calibrated or not. Then you can set the rotat ion angle.

And if  you can control the CCD temperature enter the desired value in Setpoint , and click the Set button.

When all set t ings are correct  click on the START button to start  capturing.

The telescope box will indicate the telescope posit ion, the park and tracking status and the remaining t ime to reach the
meridian.

The status bar shows the image number (count) in progress and the remaining exposure t ime

After each exposure is f inished, the image is shown and the f ile is saved according the sett ings. A message in the status bar
indicates the last  saved f ile 

it  will cont inue for the number of  exposures (=count) set .
After f inishing you could change the f ilter and start  the next series. Or automate it  fully using a sequence.

Next tutorial >>
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Tutorial
6- Automated sequence

Sequences allows you to fully automate the imaging. At the sequence tab you can specify all
steps required for unattended operat ion.

The sequence example on the right  will f irst  image the objects M13 and M92, then wait  for dawn
to take some sky f lat .

At tached to the M13 and M92 objects is the same LRGB-4H plan specifying 24 images using a
luminance f ilter (L), 8 images using a red f ilter (R) and f inally 8 images using a blue f ilter (B). All
images with an exposure of  300 seconds and the total durat ion of  the plan is around 4 hours.

After that  it  wait  for the dawn to take a series of  sky f lat .

When all is f inished it  can park the telescope and warm the camera or run other script  to close
the dome and power of f  the observatory.

Running this sequence should keep the equipment unattended busy for around 8 hours.

The current implementat ion support  only sequent ial processing of  the targets, a more
sophist icated scheduler is planned for version 2.0,

To take full advantage of  this automat ion you need to conf igure and test  individually:

all the previous tutorial pages
the camera opt ions
the astrometry resolver for plate solving and the slewing opt ions
the focuser and autofocus opt ions and calibrat ion
the rotator connect ion and calibrat ion.
the autoguider connect ion and preferences
the planetarium connect ion to help to set  the object  coordinates
the automated meridian f lip opt ions
the f lat  automat ic exposure opt ions
the weather_stat ion opt ions
the safety monitor opt ions

And most important  you must be sure your telescope mount and all the equipment include a way to protect
themselves against  an unwanted operat ion. This include hardware slew and tracking limit  on the mount.

You can read more on how to edit  a sequence in the specif ic sequence page.
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File Menu
The File menu includes the following opt ions:

Devices Setup
Bad pixel map
Dark f rame
Focuser calibrat ion

Open FITS f ile
Open picture f ile
Save FITS f ile

Open reference image
Clear reference image

Quit
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Device setup
Open this window from the menu File → Device setup before to connect to any devices.

Interface

 

The f irst  tab “Interface” let  you select  the kind of  drivers you want to use, INDI, or ASCOM if  running on Windows.

Create a new prof ile for your equipment.
All the devices and all the program opt ions will be stored in this prof ile, allowing to have completely dif ferent set t ings for your
dif ferent equipments or locat ions.

The Copy but ton copy the current prof ile to a new one, allowing to change a piece of  the equipment. 
The New but ton create a totally empty prof ile, with no equipment and no opt ions. This can be use to create a prof ile for
another observatory and be sure to not lef t  behind an incompat ible opt ion.

For INDI you have to enter the network name or IP address, and the port  of  the running INDI server, then click the button
“Connect and get devices list ” to make the program know which devices are available.
Beware that CCDciel itself  never start  the INDI server. You can start  it  using the command line, IndiStarter, or Indi
Webmanager.

For ASCOM there is no addit ional informat ion.
Note that the program will close and restart  if  you change between INDI and ASCOM.

Camera

 

Select  the camera to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.
A camera is mandatory so you cannot leave this page unconf igured.

For ASCOM you can click the Setup button to access the driver opt ions now before the camera is connected.
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You can select  if  you want the image to be f lipped vert ically when it  is read from the ASCOM driver. Keep this checked from
compat ibility with calibrat ion f rames you do with previous version of  this program.

For INDI the “sensor” f ield is to select  the sensor to use for dual-chip camera, you probably always want “Main sensor” here.
Check the corresponding box if  you want to automat ically load the INDI saved conf igurat ion when the device is connected.
Then select  how you want INDI to t ransfer the image data:

Network the normal t ransfer mode you can use with local and remote INDI server.
RAM disk may improve the performance if  you use a local INDI server. Be sure the path you set point  to an in memory
disk, it 's size need to be two t ime the size of  one of  your FITS image.

For INDI the driver opt ions are available f rom the menu Edit /INDI set t ings.

Filter wheel

 

Check “Use f ilter wheel”.

Select  the f ilter wheel to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.

Or check the corresponding box if  the f ilter wheel is commanded by the camera driver.

Focuser

 

Check “Use focuser”.

Select  the focuser to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.

Or check the corresponding box if  the focuser is commanded by the mount driver.
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Rotator

 

Check “Use rotator”.
Select  the rotator to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.

Mount

 

Check “Use mount”.
Select  the telescope mount to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.
You can send to the mount the t ime from the computer or the observatory coordinates f rom the conf igurat ion, or set  the
conf igured observatory coordinates f rom the mount GPS.

Dome

 

Check “Use dome”.
Select  the dome to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.
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Weather station

 

Check “Use weather stat ion”.
Select  the weather stat ion to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.
For ASCOM you can select  if  you want to use a ObservingCondit ion or SafetyMonitor driver. You can def ine the
ObservingCondit ion limits in the Preferences. If  using a SafetyMonitor be sure the limits are set to ensure good observing
condit ion.
For INDI the limits are the Warning level of  the weather driver.
When the observing condit ion are not good the sequence is paused unt il they are good again.

Safety monitor

 

Check “Use safety monitor”.
Select  the safety monitor to use with CCDciel, f rom the dropdown list  for INDI or using the ASCOM chooser.
For ASCOM be sure the SafetyMonitor limits are set to ensure safe operat ion.
For INDI the limits are the Alert  level of  the weather driver.
You can def ine the act ion to take when the condit ion are not safe in the Preferences. 
Beware that  by default  it  do nothing!
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Watchdog

Check “Use watchdog”, select  the INDI driver and set the threshold value in minutes.
The watchdog is a specif ic INDI driver that  can park the mount and the dome if  the connect ion is lost  with CCDciel for
more than the threshold t ime limit . There is no similar funct ion when using ASCOM drivers.

Click OK after you f inish your set t ing.
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Bad/Hot pixel map
The bad pixel map will prevent the auto-focus or slewing funct ion locking on a hot pixel rather then on a star.

The bad pixel map will be only applied on preview images, focus or slewing images. It  is not applied on captured images.
Those images are not altered.

Use the menu File → Bad pixel map → Apply to current  image If  you want to apply the bad pixel map to an image you load
in the program.
You can ident ify an image that was BPM processed with a comment at  the end of  the FITS header.

You have two opt ions to create, using the camera direct ly or using a processed dark f rame. The second opt ion is preferred
because the processed dark as less noise and you can use a lower sigma value to detect  fainter deviant pixels.

Create f rom the camera

Procedure:

1. Camera should be connected and cooling on if  available.
2. Set the required binning in Preview tool. Use the same binning as for the focus and slewing
3. Select  an exposure t ime between 10 and 60 seconds.
4. Cover the camera or telescope similar as taking a dark image. If  your camera has a shutter it  will remain closed during

the exposure.
5. Select  menu File → Bad pixel map → Create from camera
6. Click Cont inue. A dark will be taken and number of  hot pixels will be reported in the log window.

Create f rom a dark f ile

Select  menu File → Bad pixel map → Create from dark f ile

Select  the dark f ile f rom the f ile dialog.

Clear the bad pixel map

To remove/clear the bad pixel map select  the menu File → Bad pixel map → Clear bad pixel map

Check the bad pixel map

Take a preview image and check if  the bright  hot pixels are suppressed.

Or open a saved raw image and use the menu File → Bad pixel map → Apply to current  image

If  you st ill see some not removed hot pixel you can retry the procedure af ter set t ing a lower value for sigma.

20

https://www.ap-i.net/ccdciel/_detail/en/documentation/bpm_create.png?id=en%3Adocumentation%3Abad_pixel_map


Possible errors

Error: If  you get an error message: “too many hot pixels”, increase the sigma threshold value in the menu Edit  →
Preferences → preview opt ions. If  successful the program log will report  the number of  hot pixels suppressed.

. 

A typical threshold value is 5 for CCD and 8 for a modern CMOS sensors. Decrease the threshold value if  you want suppress
more hot pixels. Normally you should suppress maybe 5 to 30 hot pixels but you can go much higher.

With some camera it  is not possible to get a good result  here. In this case use a dark f rame instead.
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Dark frame
With some camera it  is dif f icult  to use a bad pixel map to cleanup the auto-focus frames. In this case you can def ine here a
dark f rame that will be subtracted to remove the hot pixels.
Beware this processing require the dark f rame is acquire with the same exposure t ime and at  the same temperature than the
auto-focus frames. This also use more resources than the bad pixel map processing. So the bad pixel map must be used in
preference if  applicable.

This same dark f rame is also used with the preview stacking opt ion.

Use the menu File → Dark frame → Apply to current  image if  you want to subtract  the dark f rom the current ly displayed
image.
You can ident ify an image that was dark subtracted with a comment at  the end of  the FITS header.

You have two opt ions to def ine the dark f rame, using the camera direct ly or using a processed dark f rame. The second
opt ion is preferred because the processed dark as less noise.

Create f rom the camera

Procedure:

1. Camera should be connected and cooling on if  available.
2. Set the required binning in Preview tool. Use the same binning as for the focus and slewing
3. Select  the same exposure t ime as used for the auto-focus.
4. Cover the camera or telescope. If  your camera has a shutter it  will remain closed during the exposure.
5. Select  menu File → Dark frame → Create from camera
6. Click Cont inue. A dark will be taken and saved for future use.

Load a dark f ile

Select  menu File → Dark frame → Load dark f ile

Select  the dark f ile f rom the f ile dialog.

The f ile must be taken with the same binning, exposure t ime, temperature than used for auto-focus. This f ile must use a pixel
format of  16bit .

Clear Dark f rame

To remove/clear the dark f rame select  the menu File → Dark frame → Clear Dark frame

Check the dark f rame

Take a preview image, select  the menu File → Dark frame → Apply to current  image
Verify the hot pixels are removed and the processing do not create unwanted art ifact .
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Focuser calibration
This funct ion help you to set  the auto-focus parameters specif ic to your focuser, telescope and camera because it  is not
immediately evident what to set  for all this numbers.

The principle is you start  by centering and manually focusing a star that  is used by the procedure to f ind how the star
diameter change with an increasing movement of  the focuser.

At the end it  propose you new auto-focus parameters you can save to the conf igurat ion.

If  you use an absolute posit ion focuser it  set  to use the V curve focusing method and give you the opportunity to learn a
new curve using the same star you already centered in the image.

To start  the procedure select  the menu File → Focuser calibrat ion

The f irst  screen give you informat ion about centering, focusing and correct ly exposing the star.
Do it  now, before to click the Next button.

The next screen let  you select  the direct ion you want to move the focuser in the auto-focus operat ions. Depending on you
sett ing the focuser can work better when moved in or out of  focus. If  you want to conf igure the temperature compensat ion,
set the direct ion to compensate when the focuser cool down during the night.

If  the focuser need a backlash correct ion you can enter the value now. But be sure to let  it  disabled if  the compensat ion is
done elsewhere.
Indicate the number of  addit ional steps to use for the compensat ion, this must be greater than the actual backlash, don't
hesitate to use a large value.
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Then it  of fer you to change two measurement parameters, the maximum defocused star diameter (HFD) it  will t ry to reach,
and the init ial movement of  the focuser in step.

You can change the f irst  parameter if  you know what your equipment can achieve, otherwise keep the default  and follow the
recommendat ion if  the f irst  t ry fail. 
The minimum movement is not really important to change because any way the program will double the value unt il it  see
enough change in the star diameter. You can just  save a few t ime if  you know your focuser need more steps even for f ine
focus.

It  start  slowly, just  wait  unt il it  reach the maximum diameter.
Then it  start  to move the focuser on the opposite side, much quickly as it  know what speed to use.
You can check if  the curve is symmetrical and as not evidence of  gross error.

Now the program know how your focusing system react.
You can review the parameters before to click Next to save them to the conf igurat ion.
Later you can view or change this values in the auto-focus parameters.

The procedure is completed and you can close this window.

With an absolute posit ion focuser the focusing method is set  to Vcurve and now you must learn a new curve for the new
parameters.
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The Vcurve learning automat ically open, already f illed with the correct  set t ing. Do not change any value and just  click the
Learn but ton and af ter it  complete click the Save but ton.

The init ial set t ing is now completed.

You can now open the auto-focus parameters and without changing any of  the detailed parameters you can change the
auto-focus method between Vcurve and Dynamic depending on your preferences.

Select  also how you prefer to run the auto-focus automat ically as part  of  a sequence. 
You have the choice to stay at  the current target posit ion and use whatever stars are present, or slew to a nearby star of
f ixed magnitude.
Later you can also alter this choice target by target in the sequence editor.

If  you use the Vcurve method it  is strongly recommended to slew to a focus star.
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Open FITS file
From the menu File → Open FITS f ile.

This let  you load a FITS f ile in the preview window instead of  taking the image with the camera.

This is useful if  you want to review a previous shot f rom the capture sequence, or to play with some other image.

Note CCDciel is not a mult i-purpose FITS f ile viewer. It  is intended to display images from the camera but it  could fail
displaying FITS f iles f rom other programs.
There is also chance CCDciel cannot plate solve a f ile taken with another sof tware if  WCStools cannot f ind the approximate
coordinates and scale of  the image.
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Open picture file
From the menu File → Open picture f ile.

This let  you load an picture f ile in one of  the following format: png, bmp, jpg, t if , gif , tga.

This support  monochrome picture both 8 or 16 bit  per pixel, or color picture 3×8 or 3×16 bit  per pixel.

The image is converted in 16 bit  FITS format to load it  in the preview window.

If  you want you can then save to a f ile in FITS format using the menu Save FITS f ile.

This is useful if  you want to review a previous shot f rom the capture sequence, or to play with some other image.
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Save FITS file
From the menu File → Save FITS f ile.

This let  you save to a FITS f ile the image in the preview window.

This is not used part  of  the capture sequence as the f iles are automat ically saved, but this can be useful to save an image
taken with the Preview funct ion or loaded with File → Open FITS f ile.

Be careful this Preview image can be processed for bad pixel if  you create a bad pixel map.
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Reference image
You can load a reference image of  the object  you want to capture to adjust  the posit ion of  the telescope and the rotat ion of
the camera. This is very useful to cont inue a sequence over many night.

You can adjust  the display threshold and the color of  the reference image in the preview opt ions. 
Normally you want the threshold to display only the stars f rom the reference image.

To load the image use the menu File / Open reference image

Then start  a preview loop, it  show the new image over the reference.

You can now move the telescope or rotate the camera to match the reference.

When you are sat isf ied with the result  you can remove the reference image from the menu File / Clear reference image

Tips:
To help to center the telescope open f irst  the reference image with File / Open FITS f ile. Right click on the image and select
“Resolve and slew to image center”. Af ter the telescope stop slewing process as above to adjust  the rotat ion.
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Quit
From the menu File → Quit .

Exit  the program and save the conf igurat ion.

If  the devices are connected you are asked if  you want to disconnect them.

30



Edit Menu
The Edit  menu consists of  the following items:

Preferences
INDI set t ings
View FITS header
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Preferences
From the menu Edit  → Preferences. Set the global preferences and opt ions for the program.

Files

Language
You can change the program language from the list  if  you prefer to use another language than the one selected
automat ically. The program must be restarted af ter changing the language.

Capture folder
The base capture folder should be specif ied. The other conf igured sub-folder are created under this one.

Temporary folder
Normally you not need to change the temporary f ile folder. This is only required on Windows if  the default  path based on
your user name contain accentuated non-ASCII characters. Be sure you specify a path with only ASCII characters.

File and folder name
You can specify how the image f iles are named and if  they are stored in named folders. A typical imaging session will produce
a great number of  f iles so it  is important to preserve the details for later processing.
One way of  working is to make subfolders based on object  name and select  for f ile names all details; object  name, the f ilter, a
date sequence, exposure t ime, binning. This is all depending on personal preferences and image processing software used
later.
For folder name you have the choice between two date. One to make a folder with the same UT t ime as for the f ile name,
the other is based on local t ime and change at  noon to allow to put all the f iles for a given night to the same folder.
For f ile name, if  Date/Sequence is checked the UT date and t ime is appended. If  it  is not checked a sequence number is
appended to make the f ile unique.

You can reorder the dif ferent elements with a mouse drag and drop of  the sequence number column.

Journaling
At the bottom you can select  to save all log messages to a f ile for further inspect ion or debugging. it  is recommended to
always let  it  checked.
You can look at  the log using the funct ion in the Help menu.
If  this opt ion is checked it  also save the images in the case the auto-focus fail to f ind stars, they can be used later to help to
adjust  the parameters.
The log f ile and failed auto-focus images are conserved for a period of  30 days, then they are automat ically removed.

And you can act ivate a TCP/IP server to get remotely the status of  CCDciel

32

https://www.ap-i.net/ccdciel/_detail/en/documentation/pref1.png?id=en%3Adocumentation%3Apreferences


Observatory

General information
The informat ions on top will be set in each FITS f ile for the OBSERVER, ORIGIN and TELESCOP keyword.

Observatory locat ion
The lat itude and longitude of  the observatory is used to get the Alt /Az posit ion of  the object , or for the scope_alignment
script . It  is mandatory you set them before you can use the t iming funct ions in the sequence planner.

Local horizon
The “Horizon prof ile” and “Minimum observing elevat ion” are used to compute the object  rise and set t ime in the sequence
planner. If  this values are set the rise/set t ime are relat ive to this limits.
You can set only one value or both. In the last  case the highest elevat ion is used.
The horizon prof ile f ile is the same as the local horizon line in Skychart .
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Preview

This set t ings af fect  only the preview, the FITS f iles are always recorded in RAW format to allow further preprocessing.

Color
If  you use a color camera you can debayer the preview image by checking the corresponding box and select ing the color
pattern for your sensor. If  you don't  know what to select , make a test  on a colorful subject  on dayt ime. You can also do
some color balance with the cursors on the right .

Reference image
The reference image help you to f rame a previous image, for example to cont inue a sequence.
Select  the threshold and color for the display of  the reference image.

Image clipping
The image clipping indicator level. You can set the low and high threshold in ADU for this indicator.

Bad pixel map
The bad pixel map prevent the auto-focus funct ion to lock on a hot pixel.
Select  the threshold for detect ion of  hot pixels for the bad pixel map.

Stacking
Preview stacking allow you to stack the preview frames in real t ime. This feature is normally use for demonstrat ion in public
event. 
You can select  to disable this opt ion to not risk an unwanted use during your imaging session.
Use the menu File → Dark frame to def ine the dark to be subtracted from the images before the addit ion to improve the
result  quality.

Video
Select  the preview rate for the video. Video require a suitable camera and is available only with INDI devices.
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Camera

CCD temperature

Conf igure how you prefer to cool down and warm up you CCD sensor.

Consult  your camera documentat ion to know if  you need to limit  the temperature change. 
In this case check “Limit  temperature change” and indicate the maximum rate in degree (Celsius) per minute.

Check the corresponding box if  you want your camera to start  cooling as soon it  is connect to the program and indicate the
target temperature you want.

Sensor propert ies

Enter the camera pixel size and maximum ADU, or if  applicable for your driver, check the box to get it  automat ically.
The maximum ADU is used to avoid saturated stars during autofocus.
The pixel size is required to speedup the astrometry solving by est imat ing the image scale.

Readout modes

If  your camera support  dif ferent readout modes you can select  which one to use for the dif ferent operat ions. Normally you
want the select  the best quality mode for Capture and a fast  mode for the other.
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Flat

Automatic f lat
Conf igure the method to use to capture a f lat  series f rom a sequence.

Twilight  f lat
For the twilight  f lat  it  is require to conf igure the automat ic exposure as the sky lightness change a lot  during dusk or dawn. 
You can also conf igure this automat ic exposure for a use with other light  source.
At each exposure the program will adjust  the exposure t ime between the two limits to maintain the image level.\
Set the shortest  exposure t ime that give an uniform sensor illuminat ion. This depend on the kind of  shutter used by the
camera.
Set the longest exposure t ime you want for a f lat . You have to take the corresponding dark separately.
Then give an image mean level range that make an acceptable f lat . Start  with 80% of your camera full range but check there
is no saturated part  in the center of  the f lat  image, specif ically if  the vignett ing is important.

Dome/Panel
Select  this method if  you use dome f lat  or light  panel.
You can also select  automat ic exposure, but at  the dif ference of  the twilight  f lat  the exposure is adjusted only once for each
f ilter, then the same exposure t ime is use for the series.
If  you need to point  the telescope at  a specif ic posit ion to f rame the panel you can enter the required azimuth and elevat ion.
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Focus

Star prof ile
Select  the size in unbinned pixel of  the star detect ion area and the size of  the zoomed window for the focus mode. If  you
use a binning dif ferent than 1×1 for the focus operat ion the window size is reduced accordingly.
Normally a single pixel star is rejected as a hot pixel. If  your opt ical conf igurat ion produce undersampled image with single
pixel star you can check this box. But be careful to make a bad pixel map to reject  the hot pixel.

Focuser correct ion
If  this is not already done by your focuser driver you can act ivate a backlash compensat ion. But be sure to let  it  disabled if  the
compensat ion is done elsewhere.
Indicate the number of  addit ional steps to use for the compensat ion, this must be greater than the actual backlash, don't
hesitate to use a large value.
Indicate the direct ion the focuser will always f inish to move, the best depend on your conf igurat ion. If  you conf igure the auto-
focus this control is disabled and will be set to the same as the focus move direct ion.
If  it  take some t ime for the focus posit ion to stabilize af ter a move you can set a delay to wait  af ter every focuser
movement. This is more likely of  use if  the motor direct ly move the primary mirror of  a SCT.

Focuser temperature compensation
If  your focuser can measure the temperature you can set here the temperature coeff icient  (in steps per Celsius) used to
adjust  the focuser posit ion between the exposures, or to shif t  the auto-focus V curve accordingly. The coeff icient  is posit ive
if  the focuser needs to move UP in posit ion when the temperature drop. The rout ine will adapt the focuser if  the temperature
dif ference is larger then 0.5 degrees.
Note that for a ref lector telescope you typically have to turn the focuser OUT to correct  for tube shrinkage. For a refractor
you typically have to turn the focuser IN since the change in refract ion coeff icient  is dominant and much larger then the tube
shrinkage.
The temperature coeff icient  will help to reduce the number of  autofocus act ions required. It  will work best when the
temperature drops slowly and all parts of  the telescope have t ime to adapt to the changing ambient temperature.

The compensat ion factor has to be measured empirical. Start  with an almost zero factor=1 and monitor the autofocus focus
posit ion in the log as funct ion of  the reported temperature. If  you suff icient  data points which show a repeatable
temperature coeff icient  enter the est imated factor in this menu. Some telescopes like a SCT could have less predictable
coeff icient  and you most likely have to disable the coeff icient  and rely on the autofocus rout ine only.
If  the factor is set  well, the result  of  each autofocus rout ine run should be close to the previous focus posit ion.

Filter offset
For each f ilter you can set an of fset  in focuser steps that will be applied to the focuser when you change the f ilter.
The f ilter exposure factor is used for the auto-focus funct ions and the automat ic sky f lat . For example if  your R f ilter require
two t ime the exposure of  the L f ilter set  : L=1 R=2
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Auto-Focus

This sect ion is init ially empty. It  can be hard to f ill with the right  values for your specif ic equipment. It  is strongly suggested you
use the focuser calibrat ion wizard to set  the correct  default  parameters.

After the wizard is run it  select  one of  the focus method Vcurve or Dynamic depending on your focuser capabilit ies. You can
return at  this page if  you want to change the method or adjust  some parameters.

 

Select  the auto-focus method:

V curve: This is the preferred method for an absolute posit ion focuser. By measuring the size of  a defocused star it
can accurately calculate the ideal focus posit ion. In advance your system has to be analyzed using the V-curve
learning tool. This rout ine will measure the star size (HFD value) as funct ion of  the focuser posit ion of  your setup. The
slope of  the two lines lef t  and right  of  the focus posit ion is constant. Temperature changes, f ilters and slippage will
only shif t  the focus but not the slope of  the two lines.
Once the V-curve (slope) has been measured accurately and saved using the V-curve learning tool, every auto focus
operat ion will be done quick and ef f icient .
This method work best with a single bright  star and you need to conf igure the focus star magnitude you want to slew
before to run the focus.
Dynamic: This method can be used with relat ive posit ion focuser. It  require you start  very near of  the focus posit ion
and it  make a small V curve every t ime.
This method also work with mult iple faint  star, it  is the best if  you want to stay in place on the object  your are imaging
for the autofocus.
Iterat ive: A dumb method that move in one direct ion or another as long the star diameter is smaller. I as the
advantage to work with any kind of  focuser and you can start  with a very defocused star. But it  is slow and imprecise.
None: If  you want to use your focuser only manually.
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Common parameters

Exposure t ime to use for the auto-focus operat ion. This t ime is mult iplied by the f ilter exposure factor above.
Binning to use for the auto-focus. Use binning 1×1 unless you are way oversampled.
The move direct ion of  the focuser. Depending on you sett ing the focuser can work better when moved in or out of
focus.
Autofocus tolerance is the maximum HFDthat can be considered as a successful focus. If  the HFD after and auto
focus operat ion is higher than this value the focuser posit ion is set  back to it 's previous value.
The minimum SNR of  the star during the measurement. If  a measurement SNR is higher than this value the auto focus
operat ion is canceled and the focuser posit ion is set  back to it 's previous value.
Number of  exposure per point  The number of  exposure we take to get a mean HFD value for each focuser posit ion.
Increase this value if  the seeing is not good. But set  to 1 when using mult iple stars detect ion.
Default  behavior for focus star select ion. Select  if  you want to slew to a bright  star or stay on the object  you are
imaging to do the auto-focus. This can be selected object  by object  in the target editor.
Focus star select ion when using “Slew to focus star”. Select  the magnitude of  a star that  give a good SNR for the
auto-focus operat ion using the above exposure t ime. The telescope is moved to a nearby star of  this magnitude to
run the auto-focus. You can set here the precision require for the slew to put the star in half  the image height. Use a
lower precision than for target slewing to speedup the process.

Method Target  f ield V- curve focusing Dynamic focusing

Slew to database star Always a bright  star +++ +++

Stay in place Medium bright stars ++ +++

Stay in place Faint  stars + ++

Stay in place Narrow band f ilter + faint  stars - -

Dynamic focusing can work in the bottom non-linear part  of  the V-curve. HFD as low as 3 (twice minimum)

V-curve requires HFD in 15-10 range minimum. Below HFD 10 not opt imal performance.

If  the auto-focus fail to f ind stars and the journaling to f ile is act ive, the image is saved in the same folder as the log so you
can review them later to help to adjust  the parameters.
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V curve parameters

Start  focus HFD: The focus start ing point  on the V curve used to determine the Near focus posit ion. Use a high value
near the top of  the V curve but inside the measurement area. A typical value is 20.0.
Near focus HFD: We move the focuser to get this HFD to make the measurement on the V curve. This is not  the
focus HFD, it  must be half  way on the linear part  of  the curve. For example if  your focus HFD is 3.0 and you make a V
curve up to a HFD of 20.0, you can set 10.0 here.
Slippage correct ion If  your focuser is prone to slippage you can act ivate a correct ion here. You must have conf igured
the f ilter offset  and the focuser temperature compensation, so we can be conf ident that  the remaining of fset  is
slippage.

The autofocus rout ine f inds the focus in four focus movements using the slope informat ion from the V-curve learning.

1. Move beyond the Start  focus HFD to (1) taken into account any temperature drif t . This
to f ix any mechanical hysteresis in your system.

2. Move to calculated Start  focus HFD (2) taken into account any temperature drif t . Here
a number of  exposures is taken and the average new start  HFD is calculated.

3. Based on the average new start  HFD of step 2) move using the slope factor to the
calculated Near focus HFD posit ion (3). This (3) will be already adapted to any focus
drif t  and should be spot-on. Take a number of  exposures and use the average new near
HFD and slope factor to calculate the new focus posit ion.

4. Move to the new calculated focus posit ion (4).

- If  the SNR, signal to noise is too low, the rout ine is aborted.
- Any focus drif t  will result  in a drif t  of  the new start  HFD but not in the new near HFD.
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Dynamic parameters

Number of  dynamic points: The number of  points we take on the curve. Do not set  too high as this is done at  every
focus operat ion. Recommended default  value is 7.
Movement between points: The number of  focuser steps we move between each measurement of  the curve. It
must be set high enough to make a measurable change in star diameter, but  not to high so faint  stars can st ill be
detected. The maximum focuser movement in and out of  current posit ion will be (Number of  dynamic
points)*(Movement between points)/2

Iterat ive parameters

Init ial movement  in focuser steps. This is the movement we use between measurement on the f irst  iterat ion. It  is then
divided by two every t ime we change the direct ion.
Final movement  in focuser steps. When we reach this movement value we consider we are at  the focus. This is
typically the focus tolerance of  your opt ical system.
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Astrometry

 

Global opt ions
It  is important the program know your telescope focal length to est imate the image scale to speedup the solving process.
Enter telescope focal length, or if  applicable for your driver, check the box to get it  automat ically.

You can also adjust  the t imeout (in seconds) for a solve operat ion.

Software select ion
Select  the software you want to use for the astrometry resolut ion of  the images, you can use astrometry.net , Elbrus
star locator , PlateSolve 2 or ASTAP.

For each software you can adjust  a few opt ion to make them work quickly and reliably with your images.

Astrometry.net  opt ions

Maximum search radius: Is a tolerance in degrees to the telescope posit ion. Set this value high enough if  you use the
plate solving to make a point ing model.
Scale tolerance: The tolerance on the pixel scale derived from the focal length and pixel size.
Downsample: the image by this factor. Use at  least  4 or 8 for DSLR images. For CCD it  is better to use binning.
Maximum number of  source to consider.
Create plot  of  the result : create png image with indicat ion useful for debugging.
Other opt ions: any other opt ion you want to give to the solve-f ield command.
Use custom script : Use a script  instead of  the solve-f ield command. There is two example with the program, one for
remote execut ion using ssh, the other for remote solving with the astrometry.net python script .
On Windows only, you need to specify the Cygwin path to where astrometry.net is installed, for example C:\cygwin.
See the installat ion instruct ion for more details.

Elbrus options

Elbrus images folder: the folder where Elbrus wait  for new images to solve.
Images folder Unix path: Unix only, the unix path corresponding to the previous one where CCDciel save the image for
measurement.
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PlateSolve 2 opt ions

Program folder: the folder you install the PlateSolve2 program.
Wait  af ter solve: the number of  second the PlateSolve2 window remain visible af ter solving is complete.

ASTAP options

Program folder: the folder you install the ASTAP program.
Maximum search radius: Is a tolerance in degrees to the telescope posit ion.
Downsample: For large images (>3000 pixels wide) select  binning.
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Slew

You can adjust  how to correct  the mount posit ion af ter plate solving a control picture.

Correct ion method
If  your mount allow to sync anywhere select  “Mount sync”, if  not  select  “Point ing of fset” to make the correct ion in sof tware.
Use “Point ing of fset” if  your telescope use a point ing model, this avoid any problem by using Sync with the model, but  this
can result  in a wrong posit ion to be reported in other sof twares.

Point ing options
Then set the precision you want/can reach and the maximum number of  point ing/correct ion retry before to give up.

Set the parameters (exposure t ime, binning and f ilter) for the control exposure. This must give enough stars with your
telescope/camera combinat ion for the astrometry resolver to work.

If  your mount need some t ime to stabilize af ter the movement you can increase the delay to wait  before to take the plate
solving picture.
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Meridian

Conf igure here what you want to do when the mount reach the meridian.

Do nothing: select  this opt ion if  your mount is not af fected by the meridian (fork mount).
Automatic f lip: automat ically do a reversal of  the mount to cont inue to t rack past meridian.
Abort: abort  the current capture and stop the mount.

Automatic f lip opt ions

Can track past  meridian for: the number of  minute your mount can safely t rack past the meridian without f lip. This
depend on the declinat ion, set  the smaller value here.
No f lip unt il past  meridian for: the minimum number of  minute af ter the meridian we wait  before to init iate the f lip.
This two parameters allow to loss the minimal t ime during a capture sequence, otherwise you can wait  for a long as a
single exposure t ime.
Autofocus after meridian f lip: In some case the focus point  can move af ter a f lip.
Calibrate autoguider after meridian f lip: If  your mount do not report  the side of  pier to the autoguider you must
check this opt ion.
Pause before meridian f lip:
Pause after meridian f lip: this two checkbox give you a prompt before or af ter the f lip to let  you the t ime to do
some manual operat ion on the mount (moving the counterweight for example).
Timeout: The maximum t ime we wait  for the af ter meridian pause, if  you not close the prompt af ter this t ime the
sequence cont inue automat ically.
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Autoguider

Software select ion
Select  your autoguiding software, this can be PHD2 or Lin_Guider.

PHD2 options
For PHD2 you need to set  the network name of the computer running PHD2 and the port  number.

Dithering
Set the opt ions for dithering between the exposure, the number of  pixel (in the guide camera) and if  you want to dither only
in RA (if  you have a lot  of  DEC backlash).

Sett le tolerance
The sett le tolerance def ine how we consider the autoguiding as good af ter a dither operat ion or af ter it  start .
It  must stay within the number of  pixel for Min.t ime. But we wait  for the maximum of Timeout if  this is not possible.
Set also the maximum t ime to wait  if  a new calibrat ion is required.

Star lost  act ion
In the case of  guide star lost  (passing clouds…) we can try to restart  the guider af ter some t ime. This is useful if  the star as
moved out of  the search area, but if  the clouds are st ill there we can start  guiding on a hot pixel. A value of  zero disable this
funct ion.
Then we can abort  the current sequence af ter some t ime, maybe the next object  on the plan is in a clear area.

Lin_Guider opt ions
For Lin_Guider you can choose to communicate by a local Unix socket or by the TCP network, on Windows only the TCP
opt ion is available. The select ion must correspond to the one in the Lin_Guider general set t ing.

Dithering
Set the number of  pixels for dithering between the exposure.
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Planetarium

Select  the planetarium applicat ion you want to use.

You can use the planetarium to select  a target, or to display a solved image or image frame.

You have the choice between Skychart . HNSKY, or a SAMP applicat ion like Aladin or Topcat.
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Weather station

Beware this sett ings will never close your observatory, even in case of  rain! See the Safety monitor below if  you need
this act ions.

You def ine here the parameters to pause a running sequence when the weather condit ion are not opt imal.
When bad condit ion are detected the program do the following:

1. wait  the end of  current exposure
2. stop telescope tracking and autoguiding
3. wait  for the sky to be clear again

When it  is clear again it  run the target init ializat ion procedure, the same as when the target is f irst  selected, checking for t ime
range, slew with plate solving, start  autoguiding, eventually going to the next target if  this one is no more observable.

When you select  to use a ASCOM ObservingCondit ion driver, you need to set  the limits for every sensors here.

You can also set a delay to wait  af ter the weather is good again to avoid to start /stop cont inuously if  a sensor is just  at  the
limit . See also if  your driver can average the measurement over a period to avoid this behavior.

48

https://www.ap-i.net/ccdciel/_detail/en/documentation/pref14.png?id=en%3Adocumentation%3Apreferences


Safety monitor

Select  the act ions you want to run when the Safety monitor detect  dangerous condit ions.
Beware that  by default  it  do nothing!

The order to run the dif ferent act ions depend on your specif ic equipment and need to be carefully tested.
For example if  it  rain you want to close the dome as soon as possible, but maybe the mount need to be parked f irst . In this
case you must also test  what it  do if  the telescope cannot park because of  cable disconnect ion or other reason.

Use the funct ion “Call external command” if  you need addit ional act ions not available in the dropdown list .

For two act ions you need to set  a parameter:

Show prompt : the t ime to wait  before to cont inue automat ically, in seconds.
Call external command: the full path of  the command or script  to be executed.
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INDI settings
From the menu Edit  → INDI set t ings.

This menu is not act ive if  you select  the ASCOM devices interface.

This open a standard INDI client  window where you can set any specif ic opt ion for your devices.
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View FITS header
From the menu Edit  → View header.

Show the FITS header of  the current f ile.
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Tools Menu
The Tools menu let  you select  the tools you want to include or not in your screen.
Check or uncheck each tool to make it  visible or not.
You can also move each tool on another part  of  the screen to suite your need just  by dragging the tool t it le to one of  the
main window border.

It  includes the following opt ions:

Connect ion
Preview
Autoguider
Planetarium
Script
Weather stat ion
Safety monitor
Focuser
Star prof ile
Magnif ier
Capture
Filters
Frame
Rotator
CCD Temperature
Telescope mount
Dome
Sequence
Video
Visualisat ion
Messages
Clock
Reset to default

By default  many tools are grouped in four tabs on the right  of  the window.

This correspond to the main funct ionality for a capture session.

Connect ion and preview
Focusing
Simple capture
Automated sequence

You can use the keyboard F1 to F4 to select  one of  the tabs.
This same funct ion are also available f rom the main menu:
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Connection Tool

This tool let  you connect or disconnect your equipment and monitor the status.

It  is a mandatory tool as the f irst  thing to do af ter start ing the program is to click the Connect button.
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Preview Tool

This tool is to take a preview exposure for focusing or centering purpose.

Set the exposure t ime and the binning to use for the preview. 
You can also change the gain or the “ISO” if  the camera support  this set t ing

This set t ing is totally independent of  the Capture sett ing.

Click Preview for a single exposure or Loop to take exposure cont inuously unt il you stop it  with the same button. The light
change to green when the loop is act ive.

If  you act ivate the “preview stacking” in the preferences you also see a Stack check-box.
When it  is checked, every preview frame is added to the previous ones. 
Use the menu File → Dark frame to def ine the dark f rame to subtract  f rom each image before the addit ion.
If  a bright  enough star is present the f rames will be aligned on this star.

After you start  the Loop, you see the object  image to appear progressively in the screen as the number of  f rame increase.
This funct ion is of ten use in public demonstrat ion.
You can use the menu File/ Save FITS f ile... to record the stacked image af ter you stop the Loop.

A new stack is started when you start  the Loop, or af ter you take a preview without this opt ion.
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Autoguider Tool

This tool is to interface with the external autoguider.

Start  the autoguider applicat ion and then click the Connect button.

It  show the autoguider status and let  you to start  or stop autoguiding, force a new calibrat ion, or dither.

This funct ions are used automat ically by the sequence tool when the autoguider is connected.
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Planetarium Tool

This tool is to control the connect ion to the planetarium.

It  is used to display an astrometry resolved image with the right  click menu, or to set  the targets coordinates in the sequence
preparat ion.

Click the New target  but ton, click or search an object  in the planetarium, then click OK.
This make a plate solved slew to the object  posit ion and set the object  name in the Capture tool.
You must have a camera and mount connected before you can use this funct ion.

The same box is used in the sequence editor to set  the target coordinates.

Note that the target coordinates are apparent and could dif fer f rom the planetarium if  the planetarium displays the posit ion
in equinox J2000 coordinates.

56

https://www.ap-i.net/ccdciel/_detail/en/documentation/tool_planetarium.png?id=en%3Adocumentation%3Aplanetarium
https://www.ap-i.net/ccdciel/_detail/en/documentation/target_planetarium.png?id=en%3Adocumentation%3Aplanetarium


Script

This tool let  you create or run a script

The scripts can be used to automate some task in CCDciel or to interface with external program for example to manage your
observatory and equipment.

The same scripts can be used as a step in a sequence, or in specif ic condit ions, but this box is a convenient way to create,
test  and quickly run any script .
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Weather station tool

This tool show the status of  the weather monitor, when the light  is green the observing condit ion are good, for example
there is no clouds.

If  a sequence is running when the weather go bad, the sequence is paused unt il the condit ion return good.

For this tool to work you need to setup the driver and eventually conf igure the sensors limits

This is related but independent of  the Safety monitor.
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Safety monitor tool

This tool show the status of  the safety monitor, when the light  is green it  is safe to open the observatory for observing, for
example it  not  rain.

For this tool to work you need to setup the driver and eventually conf igure the act ions to take automat ically when the
condit ion change to bad.

This is related but independent of  the Weather stat ion. Some sensors of  the safety monitor can be related to the weather
but not only. You can also be interested to monitor the UPS status to be sure you have enough battery to close the dome in
case of  power outage.
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Focuser Tool
With this tool you can control your motorized focuser manually. The control are adapted if  you use an absolute or relat ive
focuser. The temperature is reported if  available.

With a relat ive focuser you can set the desired movement in steps, then click the arrow buttons < > to move the focuser in or
out.

With an absolute posit ion focuser you can set the movement as with the relat ive focuser, or set  an absolute posit ion and
click Move to.

The button V-learn start  the V-curve learning.

V curve learning

If  you not already do it , it  is strongly suggested you use the focuser calibrat ion wizard to set  the correct  default  parameters
before to use this procedure.

Introduction
In case you have an absolute posit ion focuser and want to use the V-curve auto-focus you have to run the V-curve learning
rout ine f irst .

The rout ine steps the focuser and measures at  several posit ions the size (HFD value) of  a star. This will result  in a typical V-
curve of  two lines lef t  and right  of  the focus point , The slope of  the lines will be used later in the autofocus rout ine for f inding
the focus. in this screenshot the rout ine will step from posit ion 12186+800 to posit ion 12186-800.

The focus posit ion shown as 12186 should be approximately the best focus posit ion. The maximum offset  800 as shown
should be selected such that the HFD value at  the beginning and end is above the Start  HFD focus=20 so in this example
25.
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Steps to follow
If  you are using f ilters, select  the luminance f ilter. Start  an preview loop of  about one second exposure and center on and
select  a bright  star. Run the manual focus aid and check if  the peak intensity indicat ion is about 80% of saturat ion level using
the star_prof ile tool. If  not  adapt the exposure accordingly or select  an other star.

Be sure to stop the preview loop and press the V-learn but ton

The f irst  t ime you launch this tool all the sett ings and graphic are empty.

Indicate the most accurate focus posit ion you can est imate, as you make a
manual focus just  before you can click the Get current  but ton here.

Set the Max of fset  value such that moving to the best focus posit ion plus this
of fset  give a defocused image with an HFD around 25.

Set the number of  step to 30, this is a good value that allow for precision curve.
But for the f irst  t ry you can save some t ime by sett ing it  to 10. Just  remember to
repeat with 30 when you are accustomed with the procedure.

When this three numbers are set click the Learn but ton on the bottom.

This curve is slowly build up unt il the procedure is f inished. Progress in is also
reported in the Log and Star prof ile tools.

After the measurement are completed the curve should look as in the screen
shot here. The graph shows the HFD value as funct ion of  the focuser posit ion.

Check the following important points before you cont inue:

The curve must be centered with top lef t  and right  about at  the same level
focus in the middle.
It  must extent to about the double of  the value of  Near focus HFD in the opt ions, indicated by a blue line here.
The two branches of  the V must show a long linear part , specif ically on the side of  the base of  the focus direct ion
arrow (right  on the screen shot).
The branches must not f lat ten on the top. If  you remark such behavior you must reduce the Max of fset  value.
The move direct ion should be such that the learn rout ine moves the focuser in the same the direct ion as you have to
adjust  the focuser manually during the night when it  is cooling down. If  not  change the direct ion in set t ings. For a
ref lector (mirrors) type of  telescope you typically have to turn the focuser out if  the temperature drops. For a refractor
(lenses) type of  telescope you typically have to turn the focuser in.

At the center of  the V with the points marked in red. 
It  is important to exclude this points f rom the linear regression and you can use the Fit  cursor to exclude more or less points.

When you adjust  this cursor, look to maximize the Quality value on the right  but also check the aspect of  the black
regression line across the green circles. The linearity must be specially good at  the intersect ion with the blue line.

When you are sat isf ied by the result  click the Save but ton. This will save the curve parameters and mean temperature for use
in the auto-focus rout ine.

You can now try the Autofocus in the Star prof ile tool.
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Star profile Tool
With this tool you can check the focus or start  an autofocus run. It  can be used with motorized
focuser or manual focuser.

Make f irst  a preview exposure and double click on a non saturated star.

The top curve is a cross-sect ion of  the star image. Try to make it  as narrow as possible.

Below the previous relat ive HFD measurement in red and the intensity in green.

The HFD (Half  Flux Diameter) unit  is pixels.

The FWHM (Full Width at  Half  Maximum) units are pixels and arc-seconds.

Opt imum focus is reached when HFD and FWHM are at  minimum.

The star peak intensity should be not be saturated.

Click Manual focus aid to start  a preview loop on the selected star area. See zoomed

Click Autofocus to start  the auto-focus procedure on the selected star. You must have
conf igured the auto-focus in advance and if  applicable run the V curve learning tool and saved the result .

When the autofocus is running it  show a plot  of  the HFD versus the focuser posit ion. The aspect of  the plot  depend on the
selected focusing method.

Vcurve Dynamic Iterat ive

If  you move the mouse over the graph it  display the values of  the focuser posit ion and HFD.
You can click a button to not close the graph when the auto-focus is completed to let  you more t ime for examinat ion. Click
the button again to close the graph.
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Click Image inspection to detect  the stars in your image and indicate the HFD for each and plot  a t ilt  indicator in the image.

The t ilt  is indicated in the log as % rat io between the best and worst  corner median values. In addit ion as an graphical
indicat ion it  draws an trapezium in the image based on the four median values.
There can be some variat ion in images of  the same series, so a t ilt  of  maybe 20% looks normal but anything more indicates a
camera mount ing problem.

The message in the log also display a curvature indicator that  show the rat io between the center and the corner of  the
image. This is an help to adjust  the opt imal distance between the f ield f lat tener and the camera.
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Magnifier Tool
This tool show a magnif ied part  of  the image below the mouse cursor.

The zoom level is at  least  of  2x, or 3x the main image zoom level.
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Capture Tool
This tool is to take a series of  exposures.

Set the exposure t ime, the gain if  supported, and the binning to use.

Enter an object  name. The object  name will be used for the f ile name and stored in the FITS
header at  keyword OBJECT.

Set the number of  consecut ive exposures to be taken.

Select  the type of  f rame: Light for sky exposure. Bias, Dark, Flat  for the calibrat ion. This select ion
will be used for the folder name and stored in the FITS header at  keyword IMAGETYP. If  your
camera has a shutter, it  will be closed for Bias and Dark.

If  dithering is required, put a checkmark and enter the image interval. Dithering requires the autoguider to be connected,
conf igured and guiding from the Autoguider tool before you start  capturing.

if  autofocus is required, put a checkmark and enter the image interval. Autofocus must have been conf igured in auto-focus
and V curve learning should have been run and result  saved. For autofocus the telescope will automat ically slew to a
database star of  conf igured magnitude. The slew to and return will only work accurately if  you have conf igured the plate
solver and slewing opt ions.

Click the Start  but ton to begin the exposure series. The same button can be used to interrupt the series.
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Filter Tool

With this tool you can control your f ilter wheel.

It  will show the current ly mounted f ilter.

To change the f ilter, select  one from the list .
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Frame Tool

This tool is to set  the sensor area used for imaging.

The f irst  row is the horizontal start ing point  and width.
The second row is the vert ical start ing point  and height.

You can set the values with the mouse on a preview exposure. Press the Shif t  key and the mouse lef t  but ton to draw the
frame.

Click the Set button to send the values to the camera.

Click the Reset button to reset to full f rame.
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Rotator Tool

With this tool you can control your motorized rotator.

To rotate to a new posit ion type the new Posit ion Angle and click Rotate.

Check Reverse if  your opt ical conf igurat ion require to reverse the rotat ion to match the celest ial posit ion angle.

The light  is red when the PA f ield is the rotator raw value without calibrat ion.

Use the right  click menu Resolve and sync the rotator to calibrate the rotat ion angle. After that  the light  is green and PA
f ield indicate the celest ial posit ion angle.

The last  calibrat ion is restored when the rotator is connected.
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CCD Temperature Tool

With this tool you can set the camera cooling setpoint  and read the current imaging sensor¹ temperature.

To start  cooling, enter the temperature Setpoint  (target) and click on the Set  but ton. Automat icaly the Cooler check mark
wil be checked.

To stop cooling un-check Cooler

If  you have conf igured a maximum temperature rate the button text  change to “Cancel” to let  you cancel the current
temperature change.

¹) CCD or CMOS imaging sensor.
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Telescope Tool

This tool display the current telescope RA/DEC posit ion, the side of  pier if  reported by the driver, the t ime to or f rom the
meridian.

You can park or unpark the mount using the corresponding button.
The Track button start  the mount t racking.

Use the planetarium or the sequence tool if  you want to move the telescope at  a new locat ion f rom CCDciel.
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Dome Tool

This tool show the status of  the dome.

The f irst  light  is green when to dome shutter is open, it  is red when closed.

If  applicable, the second light  is green when the dome is slaved to the telescope posit ion, it  is red when not slaved.

CCDciel do not take any act ion to init ialize the dome, do homing, unpark or open the shutter. But this is checked before to
start  a sequence and the dome can be closed and parked at  the end of  a sequence or when the condit ion are not safe.

To init ialize and slave your dome at the beginning of  the night you can use the software provided by the dome manufacturer,
the ASCOM Dome Control Panel, or the INDI control panel.

If  you have a script  to init ialize the dome you can run it  when you launch CCDciel, part  of  the Startup script . Or if  you prefer in
a script  you run at  the beginning of  the sequence.
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Sequence Tool
This tool is to control a sequence of  exposure on one or more objects.
The current implementat ion support  only sequent ial processing of  the targets, a more sophist icated
scheduler is planned for version 2.0,

The top grid show the current list  of  targets.

You can Load an exist ing f ile with a list  of  target, create a New one, Edit  the current list , Copy to a new
list  or Delete a list .

Use the Start  and Stop but ton to start  or interrupt a sequence.

When the sequence start  it  f irst  check if  the autoguider and camera cooling are available and try to start
them if  not . If  the telescope is parked it  will be unparked.

The Run unattended check box control how the program react in case of  error.

If  is not checked a message prompt you on the screen what you want to do.
If  it  is checked the operat ion is canceled. Also the terminat ion act ions are always taken anyway the sequence is
stopped.

The bottom grid show you the plan for the current target.
When the sequence is running the current target and step is highlighted.

Sequence editor

After you click New or Edit , the target editor let  you modify the list  of  target and the plan steps.
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Target list
Add a target

A target can be an object  you want to take the images, a script  to run in the sequence, or a series of  twilight  f lats. Click the
corresponding button to add the target you want.

You can edit  a value direct ly in the table or change the values for a whole column by a click in the column t it le.

Image an object

You can type the object  name and coordinates in the corresponding box or click the Planetarium but ton to select  the object
in the connected planetarium applicat ion. 
The coordinates can also be selected by plate solving the current  image.
Or click the No move but ton to not change the telescope posit ion.

Note that the target coordinates are apparent and could dif fer f rom the planetarium if  the planetarium displays the posit ion
in equinox J2000 coordinates.

Select  the exposure plan to apply to this target using the dropdown box, or type a new plan name to create a new empty
plan. After a plan is selected you can change it 's propert ies on the lower part  of  this screen. Use the Plan Save as.. but ton
to make a copy of  an exist ing plan.

The plan are saved in separated f iles and can be shared by many target list . This way you not have to edit  the detail of  the
plan every t ime, so be sure to save the plan with a new name if  the change you do is only for this target.

If  you are imaging a fast  moving asteroid or comet you can check Update RA+Dec to ask the planetarium for the object
coordinates just  before the telescope is slewed to the target.
Be sure the planetarium is connected before to run the sequence.
Check the name of the object  is compat ible with the search funct ion of  the planetarium. No problem if  you set the coordinate
and name from the planetarium.
The planetarium must be set to follow the system t ime, otherwise the asteroid posit ion is not updated.

Check Use astrometry… box to ref ine the telescope posit ion with an astromery solved control exposure. In this case you
are ensured the selected object  is f ramed exact ly as required.

You can check Stay in place for autofocusif  you are sure that the center of  the image f ield contain suitable stars for auto-
focus. It  is recommended to use the Dynamic focus method in this case.
If  unchecked, the telescope is f irst  moved to a focus star of  the magnitude def ined in the auto-focus preference, and
returned to the target af ter the operat ion.
The default  value for this opt ion is also set in the auto-focus preference.

Type the desired value in the PA column to move the rotator at  the specif ied angle. 
You can also use the current image orientat ion af ter plate solving.
Be sure the rotator is calibrated before to start  the sequence if  you use celest ial PA.
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Set the begin and end t ime

You can set a t ime range for this target to be imaged, it  will wait  for Begin t ime to start . If  End t ime is reach during the
exposure plan it  is stopped and the next target is selected.
Select  rise or set  in the dropdown to automat ically use the rise or set  t ime of  the object  above the limits you def ine in the
Observatory conf igurat ion, for the date of  the observat ion.
To not use this funct ion click the Any t ime but ton.

You can also select  to skip a target that  not meet the begin/end condit ion instead of  wait ing. This can be useful if  you have
a list  of  target you repeat over the night using the opt ion Repeat the whole sequence and take the object  when they are
visible.

You can also select  to skip a target if  it  is not fully dark night  because of  the twilight  or because of  the Moon. This way you
can skip the faint  target when the Moon is up and take them at the next repet it ion af ter the Moon is set .

You can also def ine when the whole sequence start  and stop.
Check the box Start  at “ or Stop at ” and enter the t ime you want.
Check dusk or dawn to adjust  the t ime for the astronomical twilight  for the date of  the observat ion.

Repeat a target

You can set this target to repeat  it 's whole plan for a number of  t ime at  a given interval between two consecut ive start .
Set the number of  repet it ion in the target list .

More opt ion are in the right  pane. The interval is measured between two consecut ive start  of  the sequence, this is not the
delay to wait . If  the interval is smaller than the total plan durat ion the next repet it ion start  immediately. 
You can also start  a preview loop while wait ing for the next repet it ion, this is useful to keep the Sun or Moon centered if  you
do an eclipse sequence.

Add a script

To add a script  you just  have to select  the one you want f rom the list , or create a new script  here.
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Add an automatic twilight f lat

To add an automated f lat  click the Sky f lat  but ton. 
Note: to take a dome/panel f lat  set  a standard No move target and use a plan with an image type = Flat .

Set if  you want the f lat  series to be taken at  dusk or at  dawn, this change the posit ion in the list .
Select  the number of  f lat  to take for each f ilter, the binning and f inally check the f ilters to use.
The automat ic exposure t ime must be conf igured in the f lat  preferences.
To better manage the changing sky luminosity the f ilter are selected from the darker to the lighter at  dusk, f rom the lighter to
the darker at  dawn. This require you conf igure the f ilter exposure factor.
When you add a sky f lat  to the plan this disable the “Start  at  dusk” and “Stop at  dawn” global opt ions. Do not re-enable them
otherwise the sequence will not  run during the twilight  and the f lat  are bypassed.
For the same reason you must be careful the sky f lat  remain in f irst  or last  posit ion in the list . The only acceptable steps
before or af ter them are script  to manage the equipment because they will run in full daylight . The f lat  and this scripts are run
only one t ime if  the Repeat the whole sequence opt ion is set .

Repeat the whole sequence

You can also repeat the whole list  a number of  t ime by checking the box at  the top of  the list .
There is no opt ion for the interval here, the repet it ion is immediate. But you can add scripts in the sequence to delay the
execut ion in a more f lexible way.

Termination options

You can conf igure the act ion to take af ter the sequence is f inished. The color dot are a reminder of  what opt ions are
current ly act ive, click the button to open the sett ing screen.
This act ions are not taken when you voluntarily stop a sequence with the Stop button and the Unattended checkbox is not
checked.

Select  the act ions you want f rom the list , for more act ion you can use a script .
In case of  error an addit ional script  can be conf igured for more act ions.
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Import observing list f rom Skychart

You can import  an observing list  f rom Cartes du Ciel / Skychart .

Click the corresponding button to select  the observing list  you have saved from Skychart . All the objects f rom the list  are
imported with their coordinates.
The other opt ion like the plan to use, the astrometry or the autofocus opt ions are copied from the current target. If  you
import  to an empty sequence, be sure to conf igure the default  target so this is copied to the data you import , then remove
this target af ter the import  is completed.

Manage the target list

You can add a new target, script , f lat  or delete one with the four buttons at  the bottom of the list .
You can change the target order with a mouse drag/drop on the f irst  column of the list .

The target list  is saved when you click the Save or Save as.. but ton at  the bottom right  of  the window.

Restarting a sequence
When running a long sequence you may f ind it  not  f inish during the night and you need to restart  it  a next night to complete
the missing frames.
There can be a number of  reason for that , maybe you just  put too many frames to be taken in a single night, maybe the
clouds invited themselves in the middle of  the night or some cable decided to unplug itself .

For this version CCDciel do not include an automat ic restart  capability to cont inue the sequence where it  was stopped. This
must be added for a future version.

For now the recommended way to handle such case is the following:

Copy the sequence with a temporary name such as “M13-restart”
Open this copy for edit ing
Delete any target that  where completed successfully
Eventually modify the number of  repet it ion
If  a target was part ially done :

Edit  the plan to remove any step that are completed
Change the number of  exposure for a step part ially done
Eventually modify the number of  repet it ion
Use “Save plan as” to copy the plan with a temporary name such “LRGB-4H-restart”

Save and run this modif ied sequence
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Plan steps list

Use the plan list  to specify the
exposure steps to take of  a target.

Add a step

Give a descript ion of  the step that can
be used to make a subfolder.

Set the type of  f rame, exposure t ime, binning, f ilter and number of  exposure, as in the Capture tool.

The Gain, Autofocus and Dither opt ion are set in the right  pane.
Check corresponding box if  you want to run an auto-focus at  the start  of  this step. 
For long steps you can also repeat the auto-focus af ter a given number of  images.

Manage the steps

You can add a new step or remove one with the two button at  the bottom of the list .

You can change the steps order with a mouse drag/drop on the f irst  column of the list .

The plan is saved when you click the Save or Save as.. but ton.

If  you no more need this plan you can delete it  with the Delete plan but ton
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Video tool
This tool is only available for INDI camera with video stream capability, specif ically on Linux and Mac. 
Because of  the way INDI record the video, the f ile is writ ten on the computer running the INDI server.

The video tool appear in a new tab af ter the Sequence if  the INDI camera you connected as
video stream capability.

You must f irst  set  the preview rate in the Preview opt ions. Do not use a too high value as this
preview frames have to t ransit  by the network.

Check Preview to visualize the frames.

Select  the exposure range in the drop down box then adjust  with the cursor.

Depending on the camera there can be other set t ings for the Gain, Gamma or Brightness.

The More sett ings but ton open the INDI client  for this camera, this let  you to access some
propert ies specif ic to your camera.

Two more drop down list  are to select  the image size and the frame rate.

Next are the video capture opt ions, you can limit  the capture t ime or the number of  f rames.

The object  name is use for the f ilename the same way as the stat ic images.

Click the Start  to start  recording. The recording to the video f ile is alway direct ly done by the INDI
driver without any act ion f rom CCDciel.

Use the Stop but ton if  you want the stop the recording before the planned end.
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Visualisation Tool
This tool is to control the aspect of  the preview image. None of  the sett ing here have any inf luence to the image saved as a
FITS f ile. They are only to help you to view the most of  detail on the single raw images.

It  is separated in two part , an histogram of the image and the control but tons.

On the top lef t , two rows of  buttons are to control the range of  histogram drawing, using from 90% to 98% or the full
histogram range. Reducing the histogram range help to see faint  nebulae in the image.

Bellow you can adjust  the Gamma value for the display. This also help to better see the faint  part  of  the image but without
saturat ion of  the bright  area.

The four right  button are preselected zoom level for the image.
You can also get other zoom level using the mouse wheel rotat ion
When the zoomed image is bigger than the screen you can move it  with the lef t  mouse button.

On the histogram you can move the high (green) and low (red) clipping bar with the mouse.
You can also direct ly edit  the low and high threshold by moving the mouse cursor to the top lef t  or right  to display the edit
box.

The bull eye button show the mark on the image. If  the image is plate solved it  also display an arrow with the North and East
direct ion and print  the image rotat ion angle.
A focus star can be automat ically selected in the square that circumscribe the external circle.
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The (i) but ton let  you check for saturat ion in the image.

The overf low in the highlight  area is marked in pink.
The clipped shadows area is marked in yellow.

You can def ine the clipping level for your camera in ADU in the preferences, the default  are 0 and 65535.

80

https://www.ap-i.net/ccdciel/_detail/en/documentation/tool_visu3.png?id=en%3Adocumentation%3Avisualisation


Logging

This text  window will report  all messages (Log) f rom the program and drivers.

If  conf igured, the messages (log) will be also stored in a text  log f ile for further study. It  essent ial to use this opt ion if  you let
the program run unattended.

The f ile locat ion is:

Linux:
/home/[your user name]/.conf ig/ccdciel/Log

Windows:
C:\Users\[your user name]\AppData\Local\ccdciel\log

Note that above folders are typically hidden.

The Help menu provide a quick access to this folder and the current log f ile.
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Clock
This tool show the current local t ime in the menu bar.

This is useful if  you not have another clock on the computer screen but you may want to disable it  if  you use some remote
desktop display on a slow network.
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Help
Some help to use the software.

PDF documentat ion open the PDF documentat ion installed with the software

Online documentat ion open the documentat ion in a web browser

User group open the user group in a web browser. This is the place to ask quest ion about the program use.

CCDciel status open the CCDciel status page in a web browser

Show current  log open the current log f ile using the default  text  editor

Browse log f iles open the log f ile folder in the f ile explorer

Report  a problem open the CCDciel bug tracker. You can report  here any error you encounter in the program.

Download latest  version open the SourceForge download page. Ignore this entry if  you use a package from your
Linux distribut ion.

About  show the program version and copyright not ice.
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Right click menu
Right click on the preview image to show the following menu:

Plate solving functions
The image will be resolved (plate solved) and if  successful, the image posit ion, pixel size and orientat ion will be saved in the
FITS f ile.
A second resolve request for the same image will use the saved solut ion, for example you can f irst  show the image in the
planetarium, and then slew to cursor without running the plate solver again. 
Once the image is resolved the astronomical posit ion of  the mouse cursor will be displayed at  the lef t  bot tom status bar in
apparent coordinates.

Resolve

Resolve the image using the astrometry sof tware and load the solved image in the preview.

The image show an arrow with the North direct ion, or a cross at  the posit ion of  the Pole if  in the image f ield.
You can show the RA/DEC of the cursor by moving the cursor on the image.
If  you save the FITS f ile now it  will include the astrometry solut ion.

Resolve and Slew to image center

Resolve the image using the astrometry sof tware and if  the resolut ion is successful move the telescope at  the posit ion of
the image center.

This useful to center the telescope on an image taken on a previous session.

Resolve and Slew to cursor

Resolve the image using the astrometry sof tware and if  the resolut ion is successful move the telescope at  the cursor
posit ion.

Can be useful to ref ine an object  posit ion but be careful of  the mount backlash.

Resolve and Sync the mount

Resolve the image using the astrometry sof tware and if  the resolut ion is successful Sync the telescope at  the current
posit ion.

If  you use Eqmod for your telescope driver, this can be used to set  the alignment points.
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Resolve and Rotate

Resolve the image using the astrometry sof tware and if  the resolut ion is successful set  the rotator angle to match the image
orientat ion. The rotator must be calibrated before this funct ion can work reliably.

Resolve and Sync the rotator

Resolve the image using the astrometry sof tware and if  the resolut ion is successful calibrate the rotator angle to match the
celest ial posit ion angle.

Resolve and plot DSO

Resolve the image using the astrometry sof tware and if  the resolut ion is successful draw the deep sky objects present in the
image.

Resolve and show image in planetarium

Resolve the image using the astrometry sof tware and if  the resolut ion is successful view the image in the planetarium.

Resolve and show image frame in planetarium

Resolve the image using the astrometry sof tware and if  the resolut ion is successful center the planetarium at the posit ion
and draw a frame of the CCD f ield.

View last resolver log

You can take a look at  the output log of  the astrometry resolver to help to solve a problem or to ref ine the performance.

Preview functions
The default  display mode for bayer matrix color images is set  in the preview preference. You can switch between the two
mode with this menu.

Preview debayer

Debayer and display the color image if  the current image is a raw color image with bayer matrix.

Preview raw

Display the raw image in black/white.

Image cleanup

Remove any marking and redraw the image.
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The status bar
The status bar at  the bottom of the program window show a number of  informat ion.

On the right , three lamp indicate the status of  the planetarium, autoguider and devices connect ion.

When a capture is running the status bar show the sequence number and the remaining t ime of  the current exposure. On the
right it  show the name of the last  saved image and the size of  this image.

When a preview is running it  show the remaining t ime of  the current exposure, the t ime of  the current ly displayed preview and
the size of  the image

After the exposure t ime as elapsed the remaining t ime is replaced by the advance of  the image reading process:

Downloading: the image is t ransferred from the camera to the driver.
Read image: the image is read from the driver by the program.
Display: the image is processed to show the preview on screen.

When the mouse cursor is moved over the image the following informat ion is show in the lef t  part  of  the status bar:

The X/Y image coordinate of  the cursor.
The pixel intensity.
The HFD and FWHM of the star under the cursor
If  the image is plate solved it  also show the Right ascension and Declinat ion of  the cursor posit ion, using the apparent
coordinates if  the telescope mount use the coordinates of  the date, or J2000 if  the telescope use this system. It  show
the apparent coordinates if  no telescope is connected.
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The status web page
You can open the status web page from the menu Help → CCDciel status
or direct ly f rom your web browser: ht tp://localhost:3277 
It  is also possible to get this page from another computer or phone in the local network or f rom the Internet if  you make the
required conf igurat ion in your network equipement.

This page give informat ion about the connect ions, the devices, the focus, the running sequence with complet ion indicator,
the last  image and the console log. It  refresh automat ically every minute.
Click on the image to get the full size.

If  you want to access this page remotely on the Internet, a safe way is to use Apache reverse proxy.
Install the module proxy_http in your Apache web server and add the following to a SSL virtual host conf igurat ion:

      <Proxy *>
              Require all granted
      </Proxy>
      <Location /ccdciel/>
           AuthName "protected area"
           AuthType Basic
           AuthUserfile /.../.htpasswd
           Require user myuser
           ProxyPass http://192.168.1.10:3277/
           ProxyPassReverse http://192.168.1.10:3277/
      </Location>

Where “/…/.htpasswd” is the password f ile, “myuser” a user name in this f ile, “192.168.1.10” the IP address of  the observatory
computer running CCDciel.
You can now access this page with the URL: ht tps://myhome.server.dynamic.ip/ccdciel/ , give the password for myuser … et
voila.
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TCP/IP server
If  you act ivate the server in the preferences you can connect locally or remotely to get informat ions about the program.

The program listen on port  3277 and use the following command:

status Return the devices connect ion status

sequence Return informat ions about current sequence

capture The capture informat ions in the status bar

log The last  10 lines of  the current log

quit disconnect f rom the server

For example:

$ telnet localhost 3277
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
OK! id=1

status
Planetarium connected, Autoguider guiding, Devices connected

sequence
Targets: test1 Plan: L-3x2 Start step R

capture
Seq: 2 Exp: 19 sec. Saved /home/pch/Capture/M13_Red_20180217_161453.fits 1392x1040

log
17:13:46:Saved file /home/pch/Capture/M13_Red_20180217_161346.fits
17:13:46:Starting Light exposure 2 for 20 seconds
17:14:07:Saved file /home/pch/Capture/M13_Red_20180217_161407.fits
17:14:07:Starting Light exposure 3 for 20 seconds
17:14:27:Saved file /home/pch/Capture/M13_Red_20180217_161427.fits
17:14:27:Stop capture
17:14:33:Start step R
17:14:33:Start capture
17:14:33:Starting Light exposure 1 for 20 seconds
17:14:53:Saved file /home/pch/Capture/M13_Red_20180217_161453.fits
17:14:53:Starting Light exposure 2 for 20 seconds

quit
Connection closed by foreign host.
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CCDciel Script
The scripts can be executed from the script  tool or part  of  a sequence.

There is also standard script  that  are executed on def ined occasion:

startup is executed when the program in launched, even before any device is connected. This is the place you can
automat ically connect the devices, the autoguider and the planetarium.
shutdown is executed when the program is closed.

The script  language is very powerful and allow for complex tasks.
But this can also be as simple as sending a list  of  command to dif ferent devices.

There is limitat ions if  you use an ARM processor for example with a Raspberry PI device. In this case some funct ion are not
working, specif ically the command that require a TStringList .

Script editor
The editor allow to write a script  .

The language to use is Pascal Script , based on Object  Pascal.
Def ine f irst  the global variables, then the procedure and funct ion if  any, then the private variable, and f inally the main code
start  with begin and end with end.
Read the script  example page for a quick start .

The funct ions specif ic to the interface with CCDciel are described in a separate script  reference page.

Use the Save but ton to record your change and return to the main window.

The top button are related to the debugging funct ion as describe below.
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Script debugger
Simple debugging funct ion are available to test  your code.

To run the script  in debug mode press the green arrow Run but ton. The program is f irst  compiled.

In case of  compilat ion error, the corresponding row is highlighted in yellow, and the error message is show in the bottom
message area.

If  the compilat ion f inish without error the program start  to run and stop on the f irst  code line of  the main procedure. The
current execut ion posit ion is highlighted in blue.

You can now use the Step over but ton to execute your program line by line.
The Step into but ton do the same, except if  the current line is a call to one of  your funct ion. In this case Step into allow to
run the funct ion line by line, but Step over execute the funct ion and stop at  the main program next line.

You can also set a breakpoint  on a specif ic line to jump direct ly at  this posit ion.

To set a breakpoint  click on the lef tmost column to show a red icon.
Use the Run button to jump to the next breakpoint . The current line is then highlighted in red.

You can remove a breakpoint  by clicking on the red icon or all at  at  t ime with the Remove all breakpoint  but ton.

You can display the value of  variables when the program is in pause at  a breakpoint  or af ter a Step over click.
Just click on the variable name anywhere in the program source to display the value in the message area.
Note this work only for local variables, not for object  propert ies.

You can use the Pause but ton to pause the program execut ion. This can be useful to examine the condit ion of  an inf inite
loop for example.

The Stop but ton terminate the program execut ion immediately.
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Script example
This page give t ips and example of  script ing funct ions.
You can also look at  the template code provided with the program.
For more details about a specif ic funct ion see the script  reference page.

Generality
We f irst  look in detail at  the code of  the scope_unpark script  you can use to unpark the telescope. To open this script  locate
the script  tool, select  “scope_unpark” in the dropdown list  and click the Edit  but ton.
This cover many programming basis.

The full script  code look as following:

{
  This script unpark the telescope mount
}
 
var ok,parked: boolean;
    arg: TStringList;
    r: string;
begin
 
  // telescope connected?
  GetB('TELESCOPE_CONNECTED',ok);
  if not ok then begin
    logMsg('Telescope not connected!');
    exit;
  end;
 
  // get park status
  GetB('TELESCOPE_PARKED',parked);
 
  if parked then begin
    getSl('STRL1',arg);
    arg.clear;
    arg.add('OFF');
    r:=cmdArg('TELESCOPE_PARK',arg);
    if r<>msgOK then logMsg('Telescope park: '+r);
  end
  else begin
    logMsg('Telescope already unparked');
  end;
end.                                            

Take a look at  each part  in detail:

{
  This script unpark the telescope mount
}

Is a comment, you can use // {..} (*..*) to enclose your comments.

var ok,parked: boolean;
    arg: TStringList;
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    r: string;

Define the variable we use later in the script .
Important variable type are: integer, double, string, boolean.
The Tstringlist  type is use here to send a command argument to CCDciel.

  begin

The start  of  our script .

GetB('TELESCOPE_CONNECTED',ok);

We ask CCDciel about the status of  a boolean variable to know if  the telescope is connected, the result  is in our variable ok.

  if not ok then begin
    logMsg('Telescope not connected!');
    exit;
  end;

We test  the result  of  the previous command, ok is t rue if  the telescope is connected, so we add the negat ion “not” to test
for “not connected”. If  the result  of  the test  “not connected” is t rue we execute the code block start ing at  “begin” up to the
corresponding “end”, this write a message in the log and exit  the script .

GetB('TELESCOPE_PARKED',parked);

We cont inue and we do the same to check if  the telescope is parked, with the result  in our parked variable..

    if parked then begin

We test  if  the telescope is parked, in this case we can unpark.

GetSL('STRL1',arg);
arg.clear;

Request a TStringList  object  ident if ied by STRL1. We clear any data that may stay in the object . We need this TStringlist  to
pass argument to a CCDciel command.

    arg.add('OFF');
    r:=cmdArg('TELESCOPE_PARK',arg);

Add the argument 'OFF' for the command and execute 'TELESCOPE_PARK' 'OFF'. This ef fect ively unpark the telescope and
the result  is in variable r.
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if r<>msgOK then logMsg('Telescope park: '+r);

We test  the result  is dif ferent than msgOK, in this case we write a message to the log to show the error f rom the driver.

 end.

The end of  the script .

Open a document
The following code open an html page in the default  web browser.
You can use any document type with this funct ion, the document open with the default  applicat ion the same way as if  you
double click the document in the f ile explorer.

begin
  OpenFile('document.html');
end.

Run a command
There is three dif ferent way to run an external command or program, depending if  you want to wait  for a result  or the
command complet ion or not.

No wait

If  the command can run for an undetermined t ime or do not produce an output you need to use the following form.
This example run the Skychart  program and exit  immediately without wait ing you exit  Skychart .

begin
  Run('skychart');
end.

Wait until the end of  the command

If  you need to wait  the end of  a command but it  only produce an exit  code to signal success or failure you can use the
following form.

begin
  if runWait('/bin/bash -c open_dome.sh') then
    logmsg('Dome opened')
  else
    logmsg('Fail to open the dome')  
end.

Wait for a result

The following command run the DIR command in the current directory. The result  is stored in a stringlist  and the f irst  entry is
show in the log.

var r:TstringList;
begin
  GetSL('STRL1',r);
  r.clear;
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  RunOutput('dir',r);
  logmsg(r[0]);
end.
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Script reference
This page contain reference material for script ing funct ions.

See the script  descript ion page for general informat ion.

See the script  example page for a quick start  with the programming funct ions.

Script language
The language to use is Pascal Script .
For a complete reference of  the Object  Pascal language your can read the Free Pascal Reference guide. But beware that
some feature are not implemented by the script  language, for example: no pointer, no assembler, no overloading.

In addit ion to the standard Pascal Script  feature the following CCDciel specif ic funct ion are added.

Constants

name value

deg2rad degree to radian conversion constant

rad2deg radian to degree conversion constant

msgOK returned when a CCDciel command complete successfully

msgFailed returned when a CCDciel command fail

Global variables access

funct ion GetS(varname:string; var str: string):Boolean;

Get the global string variable ident if ied by varname

varname value

LASTERROR The text  of  the last  error

Str1 .. Str10 Ten global variable for your use

funct ion SetS(varname:string; str: string):Boolean;

Set the global string variable ident if ied by varname for later use

varname value

Str1 .. Str10 Ten global variable for your use

funct ion GetSL(varname:string; var strl: Tstringlist):Boolean;

Get the global stringlist  variable ident if ied by varname

varname value

Strl1 .. Strl10 Ten global variable for your use

funct ion SetSL(varname:string; st lr: Tstringlist):Boolean;
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Set the global stringlist  variable ident if ied by varname for later use

varname value

Strl1 .. Strl10 Ten global variable for your use

funct ion GetI(varname:string; var i: Integer):Boolean;

Get the global integer variable ident if ied by varname

varname value

Int1 .. Int10 Ten global variable for your use

funct ion Set I(varname:string; i: Integer):Boolean;

Set the global integer variable ident if ied by varname for later use

varname value

Int1 .. Int10 Ten global variable for your use

funct ion GetD(varname:string; var x: double):boolean;

Get the global double variable ident if ied by varname

varname value

TelescopeRA The telescope posit ion right  ascension

TelescopeDE The telescope posit ion declinat ion

TimeNow The current t ime in TDateTime format

CCDTEMP The current CCD temperature

Double1 .. Double10 Ten global variable for your use

funct ion SetD(varname:string; x: Double):Boolean;

Set the global double variable ident if ied by varname for later use

varname value

Double1 .. Double10 Ten global variable for your use

funct ion GetB(varname:string; var x: boolean):boolean;

Get the global boolean variable ident if ied by varname

varname value

TELESCOPE_CONNECTED True if  the telescope is connected

TELESCOPE_PARKED True if  the telescope is parked

TELESCOPE_EQMOD True if  the telescope use the EqMod driver

AUTOGUIDER_CONNECTED True if  the auto-guider is connected

AUTOGUIDER_RUNNING True if  the auto-guider is running
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AUTOGUIDER_GUIDING True if  the auto-guider is guiding

WHEEL_CONNECTED True if  the f ilter wheel is connected

FOCUSER_CONNECTED True if  the focuser is connected

CAMERA_CONNECTED True if  the camera is connected

PLANETARIUM_CONNECTED True if  the planetarium is connected

PREVIEW_RUNNING True if  the preview is running

PREVIEW_LOOP True if  the preview is in loop

CAPTURE_RUNNING True if  a capture is running

Commands

funct ion Cmd(cname:string):string;

Execute a simple command cname in CCDciel.

Valid Cmd() command are:

Command Descript ion

TELESCOPE_ABORTMOTION Stop any telescope movement

TELESCOPE_TRACK Start  telescope tracking

EQMOD_CLEARPOINTS Clear EqMod alignment data

EQMOD_CLEARSYNCDELTA Clear Eqmod sync delta

EQMOD_STDSYNC Set Eqmod in Standard sync mode

EQMOD_APPENDSYNC Set Eqmod in Add point  on sync mode

AUTOGUIDER_CONNECT Connect to the autoguider sof tware

AUTOGUIDER_CALIBRATE Force a new calibrat ion of  the autoguider

AUTOGUIDER_STARTGUIDING Start  to guide

AUTOGUIDER_STOPGUIDING Stop guiding

AUTOGUIDER_PAUSE Pause guiding

AUTOGUIDER_UNPAUSE Restart  af ter pause

AUTOGUIDER_DITHER Dither now

AUTOGUIDER_SHUTDOWN Close the autoguider program

WHEEL_GETFILTER Get the current f ilter number in the wheel

PREVIEW_SINGLE Start  a single preview

PREVIEW_LOOP Start  a preview loop

PREVIEW_WAITLOOP Wait  unt il the user stop the preview loop

PREVIEW_STOP Stop any in progress preview or preview loop

CAPTURE_START Start  a capture

CAPTURE_STOP Stop a capture

ASTROMETRY_SOLVE Plate solve the current image

ASTROMETRY_SYNC Plate solve the current image and sync the telescope

ASTROMETRY_SLEW_IMAGE_CENTER Plate solve the current image and slew the telescope

PLANETARIUM_CONNECT Connect the planetarium software

PLANETARIUM_SHOWIMAGE Plate solve the current image and show in planetarium
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PLANETARIUM_SHUTDOWN Close the planetarium software

PROGRAM_SHUTDOWN Close CCDciel

CLEAR_REFERENCE_IMAGE Remove the reference image

AUTOFOCUS Run auto-focus at  the current posit ion

AUTOMATICAUTOFOCUS Move to a bright  star and run auto-focus, return to last  posit ion when f inished

funct ion CmdArg(cname:string; arg:Tstringlist):string;

Execute a command cname in CCDciel with parameters arg. Add each parameter to the string list .

Valid CmdArg() command are:

Command Arguments Descript ion

DEVICES_CONNECTION ON/OFF Connect or disconnect the devices

TELESCOPE_SLEW RA, DEC Slew to specif ied coordinates

TELESCOPE_SYNC RA, DEC Sync to specif ied coordinates

TELESCOPE_PARK ON/OFF Park or unpark the telescope

WHEEL_SETFILTER number Set the f ilter number in the wheel

WHEEL_GETFILTERSNAME arg On return arg contain the name of the f ilters

WHEEL_SETFILTERSNAME arg Put each f ilter name in arg

CCD_SETTEMPERATURE temp Set the CCD temperature

PREVIEW_SETEXPOSURE exp Set the preview exposure t ime

PREVIEW_SETBINNING bin Set the preview binning

CAPTURE_SETEXPOSURE exp Set the capture exposure

CAPTURE_SETBINNING bin Set the capture binning

CAPTURE_SETOBJECTNAME name Set the capture object  name

CAPTURE_SETCOUNT count Set the capture image count

CAPTURE_SETFRAMETYPE Light/Bias/Dark/Flat Set the capture f rame type

CAPTURE_SETDITHER count Set the capture Dither count

SEQUENCE_START sequence Load and start  the sequence

SAVE_FITS_FILE f ilename Save the FITS f ile

OPEN_FITS_FILE f ilename Open the FITS f ile

OPEN_REFERENCE_IMAGE filename Load a reference image

Delay functions

procedure Wait (wt:integer);

Wait  wt seconds before to cont inue the execut ion

funct ion WaitTill(hour:string; showdialog: boolean):boolean;

Wait  unt il the t ime is “hour”, encoded as 23:30:00 .
If  the t ime is already passed by less than 12h the funct ion return immediately, if  it  is passed for more than 12h it  wait  for
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the next day.
If  showdialog is t rue a dialog with t ime countdown is show, this dialog also allow to cancel or to cont inue immediately, it
return False if  the wait  is canceled.

Coordinates conversion

Procedure Eq2Hz(var ra,de : double ; var a,h : double);

Convert  Equatorial ra,de to Alt /Az a,h for the locat ion and t ime of  the current chart , all angle in radian

Procedure Hz2Eq(var a,h : double; var ra,de : double);

Convert  Alt /Az a,h to equatorial ra,de for the locat ion and t ime of  the current chart , all angle in radian

Formating and conversion

Function ARtoStr(var ar: Double) : string;

Return a string formated Right Ascension of  ar value

Function DEtoStr(var de: Double) : string;

Return a string formated Declinat ion of  de value

Function StrtoAR(str:string; var ar: Double) : boolean;

Convert  a formated string to Right Ascension decimal value

Function StrtoDE(str:string; var de: Double) : boolean;

Convert  a formated string to Declinat ion decimal value

Function JDtoStr(var jd: Double) : string;

Format a julian date to YYYY-MM-DD string

Function StrtoJD(dt:string; var jdt: Double) : boolean;

Convert  a formated string YYYY-MM-DD to julian date value

Function FormatFloat(Const Format : String; var Value : double) : String;

Format a decimal number according to the Format specif icat ion
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Function Format(Const Fmt : String; const Args : Array of  const) : String;

The Format Pascal funct ion

Procedure StrtoFloatD(str:string; var defval: Double; var val: Double);

Convert  a string to a f loat ing point  value. Return defval if  the string is a invalid number

funct ion IsNumber(str: String): boolean;

Return True if  the string represent a valid number

funct ion StringReplace(str,s1,s2: String): string;

Replace all occurrence of  s1 by s2 in str

Dialog

funct ion MsgBox(const aMsg: string):boolean;

A message conf irmat ion dialog. Return True if  YES is clicked.

Procedure ShowMessage(const aMsg: string);

Display a message.

Procedure LogMsg(const aMsg: string);

Write a message to the log

Run external program

funct ion Run(cmdline:string):boolean;

Execute the specif ied command. Return immediately without wait ing for the execut ion to end.

funct ion RunWait(cmdline:string):boolean;

Execute the specif ied command. Wait  for terminat ion.

funct ion RunOutput(cmdline:string; var output:TStringlist):boolean;

Execute the specif ied command, wait  for terminat ion and put the stdout to “output”. Beware this funct ion can completely
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lock the main program if  it  not  f inish in t ime.

funct ion OpenFile(fn:string):boolean;

Open a document f ile using the default  program
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Command line options
CCDciel accepts the following opt ions on the command line:

Option Parameter Function

--conf ig
-c

conf igurat ion
f ile path

Lets you specify the device conf igurat ion f ile to use instead of  the last  one you load
Example: –conf ig=default  , -c default

--
run_sequence
-r

sequence f ile
path

Automat ically connect the devices and run this sequence.
the startup script  is run before to start  the sequence. The camera cooler and the
autoguider connect ion are set according to the conf igurat ion.
Example: –run_sequence=/tmp/seq1.targets , -r /tmp/seq1.targets

--shutdown
-s

Wait  5 minutes and shutdown the program after the sequence specif ied with --
run_sequence is f inished. This opt ion as no ef fect  if  --run_sequence is not specif ied.
The sequence terminat ion opt ions are run before this opt ion is processed. The shutdow
script  is run af ter.
Example: –shutdown , -s
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Image preprocessing
It  is possible to use scripts to preprocess the new images automat ically for example at  the end of  the night ly sequence.
There is standard script  you can use direct ly or if  you have very specif ic needs you can modify them to make your own. This
page describe this standard scripts in more detail.

Using Siril
Siril is a powerful image processing software that can be automated with it 's own script ing language. You need at  least  the

version 0.9.9 to use this scripts.
Just  install the latest  version for your system, no specif ic conf igurat ion in Siril is need.

You can select  the following from any CCDciel script  select ion box:

siril_bias : Process the bias f iles and produce the master bias.
siril_dark : Process the dark f iles and produce the master dark.
siril_f lat  : Process the f lat  f iles and produce the master f lat , one per f ilter if  it  apply.
siril_light  : Preprocess all the light  f rame using the master dark and f lat .

You need to follow a standard scheme for the f ile and folder name, otherwise the script  will not  work.
In the f ile preferences you must  set  the following:

For File name option you must check only “Object  name” and if  using a f ilter wheel also set “Filter”. It  is very important
that “Date(UT)/Sequence” and any other opt ion remain unchecked.
For Folder name options you must check only “Subfolder by f rame type”. It  is very important that  any other opt ion
remain unchecked.

 

After you run the script  you can look at  the log f ile created in the CCDciel Capture folder. This f ile show all the Siril operat ions
and messages.

Usage requirement

As it  is not possible to make standard script  that  adapt to every use case you must be careful of  the following condit ion
before to use them:

Follow the f ile and folder naming convent ion.
All the light  f rames must be taken on the same condit ion with respect to the temperature, gain and exposure t ime.
The dark must correspond to the light  exposure condit ion.
The master f lat  is mandatory. If  you not want to use a f lat , create a f its f ile f illed with a uniform value.

Take and process Bias

The following descript ions will use a sequence as an example, but you can do the same by using direct ly the Capture and the
Script  tools.

First  create a plan to take the bias f rames:

Then create a sequence to run this plan and preprocess the bias:
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After you run this sequence you f ind in the Bias directory every individual bias f rame and the processed master bias:

With a cooled camera you probably not make bias every day, so just  keep the f ile Master_Bias.f its in place so it  can be used
by the other processing operat ion.

Take and process Dark

Same as for the bias, create a plan to take the dark f rames:

Then create a sequence to run this plan and preprocess the dark:

After you run this sequence you f ind in the Dark directory every individual dark f rame and the processed master dark:

With a cooled camera you probably not make dark every day, so just  keep the f ile Master_Dark.f its in place so it  can be used
by the other processing operat ion.

Take and process Flat

It  is required the Master_Bias is available before you can run this script .
We have more opt ions to make the f lat  f rames because it  depend if  we use a f lat  panel or sky f lat , and if  we use a f ilter wheel
or not.
To use a f lat  panel just  create a plan as for the dark but select  “Flat” for the type.

Then create a sequence to run this plan and preprocess the f lat .
To use a sky f lat  add an automat ic dusk or dawn Sky Flat  in the sequence.
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After you run this sequence you f ind in the Flat  directory every individual f lat  f rame and the processed master f lat :

As you probably make f lat  every day a good place to add this processing is at  the end of  the sequence, just  before to
process the light  f rames. Or you can use a specif ic f lat  sequence you run at  the beginning of  the night.

Take and process Light

It  is required the Master_Dark and Master_Flat  are available before you can run this script .
Again it  depend how you take the f lat  to chain this process. The important point  is it  run once at  the end of  the night af ter
the f lat  are processed.

If  you use a f lat  panel a good solut ion is to use the Script  opt ion in the sequence terminat ion opt ions. This ensure it  run only
once if  you set a sequence repet it ion or if  the sequence is interrupted at  dawn.

If  you use a sky f lat  you can add the script  at  the end of  the sequence af ter the f lat  processing:

After the script  is f inished you f ind the dark and f lat  preprocessed f iles for all the objects and all the f ilters in a new directory
“processed” under the base capture directory. Every f ile is pref ixed by “pp_” as Siril do to dist inguish them from the original
f iles.

By default  this script  stop here because at  this point  you probably want to review your f iles and make some select ion before
to go further.

But if  you want it  is possible to cont inue with alignment and stacking. For that you need to modify the f ile template_light.ssf
located in the CCDciel program directory in scripts/siril.
On Windows this is “Program Files\ccdciel\scripts\siril”, on Linux this is “/usr/share/ccdciel/scripts/siril”
In the f ile remove the #  in f ront of  the command “register” and “stack”. If  you use a OSC or DSLR camera you also need to
add the opt ions “-cfa -debayer” to the preprocess command to debayer the images before the registrat ion.
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Installation on Ubuntu, Debian
Bellow installat ion procedure uses only command line approach, because this is the simpler way to follow instruct ions just  by
copy-past ing the commands in terminal.

This same procedure can be used with any system using deb packages (Debian, Mint , Raspbian, …)

CCDciel and it 's dependency are available f rom the same repository as Skychart , but  you need the unstable repository as
long this program is in beta version only.

1. Install the public key:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8B8B57C1AA716FC2

2. Add Skychart  unstable repository:

sudo apt-add-repository 'deb http://www.ap-i.net/apt unstable main'

3. Update repository:

sudo apt-get update

4. Install CCDciel:

sudo apt-get install ccdciel

See also the list  of  the opt ional dependencies to install to take full advantage of  the software.
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Installation on Linux
If  your Linux system use deb packages,see Installat ion on Ubuntu.

For other Linux system you can download rpm or tar packages from the Sourceforge download link.

The requirement are Gtk2 and libpasastro.

See also the list  of  dependencies to install to take full advantage of  the software.

You can also compile the source code using Lazarus.
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Installation on Windows
CCDciel can run on any current version of  Windows. The oldest supported version is Windows 7.

The CCDciel installer is available in 32bit  and 64bit , but  be careful that  very few ASCOM driver work with a 64bit  applicat ion.
So it  is recommended to install the 32bit  version even on Windows 64.

To use the devices connected to your Windows computer you need the latest  ASCOM plat form and the most recent
drivers for your hardware.

But you can also use the devices connected to a remote Linux system (a Raspberry PI for example) using the INDI protocol.

You can download the setup installer f rom the Sourceforge download link.

See also the list  of  the opt ional dependencies to install to take full advantage of  the software.
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Installation on macOS
CCDciel can run on a recent version of  macOS, the minimal version required to run the program is 10.10 Yosemite.

To use the devices connected to your Mac computer you need the INDI library and the drivers for you hardware, available
from https://www.indilib.org/download/osx.html.

You can download the CCDciel dmg installer f rom the Sourceforge download link. Open the dmg f ile and run the installer.

See also the list  of  the opt ional dependencies to install to take full advantage of  the software.
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ASCOM
ASCOM Plat form is the standard astronomical equipment driver for Windows.

Install the latest  ASCOM plat form and the drivers you need from http://ascom-standards.org/Downloads/Index.htm or f rom
your equipment manufacturer.
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INDI
INDI Library is the standard astronomical equipment driver for Linux and macOS.

You can install INDI with the packages provided by your Linux distribut ion, but as this is a rapidly moving project  it  is best to
get the latest  version direct ly f rom the project .
For example for Debian/Ubuntu see ht tps://launchpad.net/~mut laqja/+archive/ubuntu/ppa

For macOS see ht tps://www.indilib.org/download/osx.html

There is no INDI server for Windows but you can run CCDciel on Windows to connect to a remote Linux computer, a
Raspberry Pi for example.
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ASTAP
ASTAP, the Astrometric STAcking Program, astrometric solver and FITS viewer, is a f ree stacking and plate solver program
for deep sky images. The plate solving capabilit ies can be accessed by CCDCIEL

ASTAP runs nat ively on Windows, Linux (AMD64), Raspberry PI (armhf) and MacOS. It  will require about 500 MB disk space.

Installat ion instruct ions and informat ion is available at :
ht tp://www.hnsky.org/astap.htm 

For plate solving you have to install both the program and the “G17 star database”.

Then conf igure the program path in CCDciel. For windows this is typical c:\Program Files\astap. For Linux this is typical
/opt/astap

Two ASTAP sett ings are accessible in CCDciel:

Radius search: Search radius in degrees. If  there is no match, the program will move the search f ield around in a
square spiral and increasing the distance from the init ial posit ion up to the radius specif ied. A radius of  30 degrees
could be searched in a few minutes. Blind solving is possible by sett ing this opt ion above 180 degrees. Scanning the
whole sky can be achieved in typical 380 seconds but in most cases of fset  shall be much shorter and solving much
quicker.
Binning: For large images (>3000 pixels wide) it  is benef icial to set  binning to reduce image size and increase signal to
noise rat io prior to plate solving. If  your image is around 4000 pixels wide set this binning to 2. If  your image is 5000
pixels wide set this opt ion to 2 or 3.

In MS-Windows, the execut ion of  the ASTAP solver will be shown by a small ASTAP tray icon on the right  side of  the status
bar. If  you move the mouse to the ASTAP tray icon, the hint  will show the search radius reached.

Images will require a minimum of about 30 focused stars up to more then 1000 stars. Exposure t ime as short  as 5 or 10
seconds will be in most cases suff icient . Oval stars due to t racking errors or severe opt ical distort ion will be ignored and
solving could fail.

In case the plate solving fails a more detailed log is available in ASTAP for fault  f inding. Execute the ASTAP program manually
and test  the plate solving by loading an image in ASTAP. Open the “Stack” menu (ctrl+A), open the “Alignment” tab and have
a look to sect ion “ASTROMETRIC sett ings.”. You can set the maximum number of  stars (500) and tolerance (0.005). Exit  the
program via menu f ile, exit  will save these sett ings. 

More informat ion is available at  ASTAP documentat ion
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Astrometry.net
Astrometry.net can be used to solve the image you just  take with your camera. Astrometric solving will give the exact
astronomical posit ion of  the image center, its orientat ion and size.

CCDciel requires a local copy of  the Astrometry.net sof tware including the indexes on your computer. It  can also run
Astrometry.net on a remote host using the provided script .

At  page ht tp://astrometry.net/use.html you can f ind detailed instruct ions how to install the software and indexes.

Linux

On Linux astrometry.net is probably packaged by your distribut ion. This is the easiest  and preferred way to install the
software.
For example on Debian or Ubuntu just  do:

 sudo apt-get install astrometry.net

Then to install some indexes:

 sudo apt-get install astrometry-data-2mass-08-19 astrometry-data-2mass-07

macOS

For macOS the best opt ion is to get the version from CloudMakers.

To use this version with CCDciel you need to change the following in the CCDciel Preferences at  the astrometry tab:

Check Use custom script
Enter the script  name: /Applicat ions/CCDciel/scripts/astrometry-macos.sh

If  you use another version of  astrometry.net on your Mac you must be sure it  can be called f rom CCDciel without specifying a
path. 
If  you need to add the path you can modify one of  the example script  located in /Applicat ions/CCDciel/scripts to suit  your
needs.

Windows

A number of  Windows package include a fully automated install of  Cygwin and astrometry.net and it  is best to get one of
them. CCDciel do not use this applicat ions but the astrometry.net they install. Cygwin is a tool required to run a compiled
version of  Astrometry.net under Windows.

The following list  indicate tested applicat ion and give the Cygwin path you must conf igure in the astrometry preferences.
At the t ime of  writ ing all these applicat ion use the same 2010 version 0.38 of  Astrometry.net.

ANSVR, set Cygwin path to C:\Users\[your user name]\AppData\Local\cygwin_ansvr
Install up to step 9 as indicated in the web based instruct ion.

Astrotort illa, set  Cygwin path to C:\cygwin
All sky plate solver, set  Cygwin path to C:\Users\[your user name]\AppData\Local\Astrometry

Windows subsystem for Linux, is not a real opt ion for now as it  require a 64 bits version of  CCdciel but  many ASCOM
drivers do not work f rom a 64 bits applicat ion.
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ELBRUS
Elbrus star locator can be used to solve the image you just  take with your camera.

Look at  the program page for instruct ion ht tp://www.astrosurf .com/pulgar/elbrus/elbrusin.htm

Before you can use it  the Elbrus program must be calibrated for your images. Then select  File / E-Wait  for message.

Also be sure to set  the parameter: “Add the WCS in the FITS header”.

This is a Windows only sof tware but I f ind it  easy to install and use on Linux with Wine.
On the astrometry preference you can set both the DOS and Unix path to the image data to help with this use.

To install Wine on Linux or macOS see Wine web pages.

On Linux the best way is to install the wine packages provided by your distribut ion.
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PlateSolve 2
PlateSolve 2 can be used to solve the image you just  taken with your camera. Astrometric solving wil give the exact
astronomical posit ion of  the image center, its orientat ion and size.

Look at  the program page for instruct ion ht tp://planewave.com/downloads/software/

Download and install the program and download and extract  on of  the two available star catalogs e.g. the UCAC3 in a sub
folder. Conf igure the star catalog in the PlateSolve2 program. Then conf igure the program path in CCDciel.

You could test  its operat ion manually by loading an image in PlateSolve2. It  requires an posit ion and image dimensions if  not
contained in the image header.

Linux and Mac

This is a Windows only sof tware but it  run on Linux with Wine.

Use winetricks to install the required VB6 dependency:

winetricks vb6run

To install Wine on Linux or macOS see Wine web pages.

On Linux the best way is to install the wine packages provided by your distribut ion.
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