# Created by pyp2rpm-3.3.2
%global pypi_name overpy

Name:           python-%{pypi_name}
Version:        0.4
Release:        1%{?dist}
Summary:        Python Wrapper to access the OpenStreepMap Overpass API

License:        MIT
URL:            https://github.com/DinoTools/python-overpy
Source0:        https://files.pythonhosted.org/packages/source/o/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildArch:      noarch
 
BuildRequires:  python3-devel
BuildRequires:  python3dist(pytest)
BuildRequires:  python3dist(pytest-runner)
BuildRequires:  python3dist(setuptools)
BuildRequires:  python3dist(sphinx)

%description
Python Overpass Wrapper A Python Wrapper to access the Overpass API.Have a look
at the documentation_ to find additional information. :target:

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}

%description -n python3-%{pypi_name}
Python Overpass Wrapper A Python Wrapper to access the Overpass API.Have a look
at the documentation_ to find additional information. :target:

%package -n python-%{pypi_name}-doc
Summary:        overpy documentation
%description -n python-%{pypi_name}-doc
Documentation for overpy

%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build
# generate html docs 
PYTHONPATH=${PWD} sphinx-build-3 docs/source html
# remove the sphinx-build leftovers
rm -rf html/.{doctrees,buildinfo}

%install
%py3_install

%check
%{__python3} setup.py test

%files -n python3-%{pypi_name}
%license LICENSE
%doc README.rst
%{python3_sitelib}/%{pypi_name}
%{python3_sitelib}/tests
%{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

%files -n python-%{pypi_name}-doc
%doc html
%license LICENSE

%changelog
* Sun Apr 26 2020 mockbuilder - 0.4-1
- Initial package.