# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate wast

Name:           rust-wast35
Version:        35.0.2
Release:        %autorelease
Summary:        Customizable Rust parsers for the WebAssembly Text formats WAT and WAST

License:        Apache-2.0 WITH LLVM-exception
URL:            https://crates.io/crates/wast
Source:         %{crates_source}
# Removed tests with circular dependency
Patch:          wast-fix-circular-dep.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Customizable Rust parsers for the WebAssembly Text formats WAT and WAST.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
# FIXME: no license files detected
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+wasm-module-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+wasm-module-devel %{_description}

This package contains library source intended for building other packages which
use the "wasm-module" feature of the "%{crate}" crate.

%files       -n %{name}+wasm-module-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog