# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate wasmtime-jit-debug

Name:           rust-wasmtime-jit-debug21
Version:        21.0.2
Release:        %autorelease
Summary:        JIT debug interfaces support for Wasmtime

License:        Apache-2.0 WITH LLVM-exception
URL:            https://crates.io/crates/wasmtime-jit-debug
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
JIT debug interfaces support for Wasmtime.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
# FIXME: no license files detected
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gdb_jit_int-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gdb_jit_int-devel %{_description}

This package contains library source intended for building other packages which
use the "gdb_jit_int" feature of the "%{crate}" crate.

%files       -n %{name}+gdb_jit_int-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+object-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+object-devel %{_description}

This package contains library source intended for building other packages which
use the "object" feature of the "%{crate}" crate.

%files       -n %{name}+object-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+once_cell-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+once_cell-devel %{_description}

This package contains library source intended for building other packages which
use the "once_cell" feature of the "%{crate}" crate.

%files       -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+perf_jitdump-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+perf_jitdump-devel %{_description}

This package contains library source intended for building other packages which
use the "perf_jitdump" feature of the "%{crate}" crate.

%files       -n %{name}+perf_jitdump-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+rustix-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rustix-devel %{_description}

This package contains library source intended for building other packages which
use the "rustix" feature of the "%{crate}" crate.

%files       -n %{name}+rustix-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog