## START: Set by rpmautospec
## (rpmautospec version 0.3.8)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

Name: tup
Version: 0.7.11
Release: %autorelease
Summary: A file-based build system for Linux, OSX, and Windows.
License: GPL-v2
URL: https://gittup.org/tup/
Source: https://gittup.org/tup/releases/tup-v%{version}.tar.gz
Patch0: 0000-use-rpmbuild-flags.patch
BuildRequires: fuse3-devel, pcre-devel, gcc
Requires: fuse3, pcre

%description
Tup is a file-based build system for Linux, OSX, and Windows.
It inputs a list of file changes and a directed acyclic graph (DAG), then processes the DAG to execute the appropriate commands required to update dependent files. Updates are performed with very little overhead since tup implements powerful build algorithms to avoid doing unnecessary work. This means you can stay focused on your project rather than on your build system.

%prep
%setup -q -n "tup-v0.7.11"

%patch 0

%build
./bootstrap-nofuse.sh

%install
mkdir -p %{buildroot}/%{_bindir}
install -m 0755 tup %{buildroot}/%{_bindir}/tup

mkdir -p %{buildroot}/%{_mandir}/man1
install -m 0644 tup.1 %{buildroot}/%{_mandir}/man1/tup.1

%files
%{_bindir}/tup
%{_mandir}/man1/tup.1.*

%license COPYING

%doc README.md CONTRIBUTING.md

%changelog
## START: Generated by rpmautospec
* Sun Nov 26 2023 John Doe <packager@example.com> - 0.7.11-1
- Uncommitted changes
## END: Generated by rpmautospec