# Created by pyp2rpm-3.3.8
%global pypi_name fdt
%global pypi_version 0.3.3

Name:           python-%{pypi_name}
Version:        %{pypi_version}
Release:        1%{?dist}
Summary:        Flattened Device Tree Python Module

License:        Apache 2.0
URL:            https://github.com/molejar/pyFDT
Source0:        %{pypi_source}
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3dist(setuptools)

%description
 Flattened Device Tree Python Module [![Build Status]( [![Coverage Status](
[![PyPI Status]( [![Python Version]( python module is usable for manipulation
with [Device Tree Data]( and primary was created for [imxsb tool]( Some parts
in this module have been inspired from: project.

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}

Requires:       python3dist(setuptools)
%description -n python3-%{pypi_name}
 Flattened Device Tree Python Module [![Build Status]( [![Coverage Status](
[![PyPI Status]( [![Python Version]( python module is usable for manipulation
with [Device Tree Data]( and primary was created for [imxsb tool]( Some parts
in this module have been inspired from: project.


%prep
%autosetup -n %{pypi_name}-%{pypi_version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install

%files -n python3-%{pypi_name}
%license LICENSE
%doc README.md
%{_bindir}/pydtc
%{python3_sitelib}/%{pypi_name}
%{python3_sitelib}/%{pypi_name}-%{pypi_version}-py%{python3_version}.egg-info

%changelog
* Fri Oct 13 2023 mockbuilder - 0.3.3-1
- Initial package.